Docstoc

การติดตั้งโปรแกรม OpenCV 2.0 สำหรับ VC2008

Document Sample
การติดตั้งโปรแกรม OpenCV 2.0 สำหรับ VC2008 Powered By Docstoc
					การติดตั้งโปรแกรม OpenCV 2.0 สาหรับ VC2008

OpenCV ถูกพัฒนาขึ้นเพื่อใช้เป็ นเครื่ องมือสาหรับนักพัฒนาโปรแกรมทางด้าน Image Processing และ
Computer Vision

ขั้นตอนการติดตั้ง
ดาวน์โหลดตัวโปรแกรม OpenVC 2.0 จาก http://sourceforge.net/projects/opencvlibrary/




เมื่อโหลดมาแล้วก็ติดตั้งต่อเลย
                                                           ั
ถึงตอนนี้ การติดตั้งโปรแกรม OpenCV เสร็ จสมบูรณ์แล้ว แต่ยงไม่สามารถใช้ได้
การติดตั้ง OpenCV 2.0 จะต้องทาการ Make file ใหม่ ซึ่ งแตกต่างจาก OpenCV 0.x และ 1.x

ในตอนนี้จะอธิ บายถึงขั้นตอนการติดตั้งโปรแกรม CMake ซึ่งจะใช้เป็ นตัว Make file สาหรับ OpenCV
2.0 ดาวน์โหลดตัวโปรแกรม CMake 2.8 จาก http://www.cmake.org/cmake/resources/software.html
ขั้นตอนการติดตั้ง
มาถึงตรงนี้เราได้ทาการติดตั้ง CMake เรี ยบร้อยแล้ว

ในตอนนี้จะขออธิ บายถึงขั้นตอนการใช้โปรแกรม CMake และ Visual C++ 2008
เพื่อทาการสร้างไฟล์ต่างๆ
และสุ ดท้ายจะจบด้วยการตั้งค่าเครื่ องคอมพิวเตอร์ เพื่อให้สามารถทางานได้อย่างถูกต้องตามลาดับ

เริ่ มจากเปิ ดโปรแกรม CMake โดยการคลิกที่
Start -> All Programes -> CMake 2.8 -> CMacke (cmake-gui)




ให้ทาการเลือกตาแหน่งที่ได้ทาการติดตั้ง OpenCV2.0 เอาไว้ (input) และตาแหน่งปลายทาง (output)
ตามรู ป จาดนั้นให้คลิกปุ่ ม Configure เพื่อดาเนินการต่อ
หากไม่มีโฟลเดอร์ ปลายทาง โปรแกรมจะถามการยืนเพื่อสร้างโฟลเดอร์ ใหม่ ให้คลิกปุ่ ม Yes
เพื่อดาเนินการต่อ




ตั้งค่าตัว Generator ตามรู ป จากนั้นให้คลิกปุ่ ม Finish เพื่อดาเนินการต่อ
โปรแกมจะแสดงหน้าต่างให้ปรับเปลี่ยนแก้ไขค่าต่างๆตามความต้องการ ในที่น้ ีจะไม่ทาการแก้ไขใดๆ
ให้คลิกปุ่ ม Configure เพื่อดาเนินการต่อ




คลิกปุ่ ม Generate เพื่อเริ่ มการสร้างไฟล์ต่าง
                             ้
ถ้าทุกอย่างเสร็ จสมบูรณ์จะมีขอความ "Configuring done" และ "Generating done"
ตอนนี้สามารถปิ ดหน้าต่างนี้ ไปได้




มาถึงตรงนี้ โปรแกรม CMake ได้ทาการ Make files เสร็ จสมบูรณ์แล้ว

                                                                               ่
ขั้นตอนด้านบนเป็ นการสร้างไฟล์ที่จาเป็ นโดยโปรแกรม CMake ซึ่ งไฟล์เหล่านี้จะอยูในโฟลเดอร์
C:\OpenCV2.0\VC2008
ทาการเปิ ดไฟล์ โดยการคลิกขวาแล้วเลิอก Open หรื ออาจเปิ ด Visual C++ ขึ้นมาก่อน แล้วค่อยเปิ ดไฟล์
"OpenCV.sln" ก็ได้เช่นเดียวกัน
หลังจากเปิ ดไฟล์ "OpenCV.sln" จะได้หน้าต่างของ Visual C++ 2008 ตามรู ป




ที่เมนูบาร์ ให้คลิก "Build -> Configuration Manager..."
ให้เลือกที่ "Debug" และคลิกที่ปุ่ม Close




ที่เมนูบาร์ ให้คลิก "Build Solution" หรื อ "Rebuild Solution" จากนั้นให้รอจนการทางานเสร็ จสิ้ น
ที่เมนูบาร์ ให้คลิก "Build -> Configuration Manager..." อีกครั้ง
จากนั้นให้เลือกที่ "Release" และคลิกที่ปุ่ม Close




ที่เมนูบาร์ ให้คลิก "Build Solution" หรื อ "Rebuild Solution" จากนั้นให้รอจนการทางานเสร็ จสิ้ น
มาถึงตรงนี้ การสร้างไฟล์โดยใช้โปรแกรม Visual C++ 2008 ได้เสร็ จสมบูรณ์แล้ว

                                           ่
ต่อไปเป็ นการทาให้คอมพิวเตอร์ ของเรารู ้วาตาแหน่งของไฟล์ที่ได้ทาการสร้างไว้จากขั้นตอนก่อนหน้านั้
     ่
นอยูที่ไหนกันบ้าง ตอนนี้ให้คลิกที่ปุ่ม Start -> Computer -> Properties ตามรู ป หรื อคลิกขวาที่ไอคอน
My Computer แล้วเลือก Properties ก็ได้เช่นเดียวกัน
ที่หน้าต่าง System Properties ให้คลิกที่แทป "Advance" จากนั้นให้คลิกที่ปุ่ม Environment Variables...
ที่หน้าต่าง Environment Variables ให้มองมาด้านล่างในส่ วนของ System variables
และดับเบิ้ลคลิกที่คาว่า "Path"




ตอนนี้จะมีหน้าต่าง Edit System Variables ปรากฏขึ้นมา ให้คลิกที่ช่อง "Variable value"
                             ่
และเลื่อนเคอร์ เซอร์ ให้ไปอยูทางขวามือสุ ด




ให้ทาการพิมพ์ Path ตามรู ปต่อจาก Path ที่มีอยูก่อนหน้า (อย่าลืมเครื่ องหมาย ";")
                                              ่
;C:\OpenCV2.0\VC2008\bin\Debug;C:\OpenCV2.0\VC2008\bin\Release;
คลิกปุ่ ม OK ของทุกหน้าต่างที่เปิ ดไว้ก่อนหน้านี้ท้ งหมด จบขั้นตอน
                                                    ั




มาถึงตรงนี้ ขั้นตอนต่างๆได้ถูกทาให้เสร็ จสิ้ นเรี ยบร้อยแล้ว
รายละเอียดในตอนนี้จะขออธิ บายถึงการกาหนดให้ Visual C++ 2008 สามารถดึงความสามารถของ
OpenCV 2.0 มาใช้ได้รวมไปถึงการสร้างโปรเจ็คใหม่ การคอมไพล์และการสั่งรันเพื่อดูผลการทางาน

เริ่ มจากการสั่งรันโปรแกรม Visual C++ 2008 จากนั้นให้คลิกที่ Tools -> Options... ตามรู ป
                                                                            ้
ตอนนี้จะมีหน้าต่าง Options ปรากฎขึ้นมา ให้ทาการกาหนดค่าต่างๆตามรู ป (ยังไม่ตองคลิกปุ่ ม OK)




       ั ่
ตอนนี้ยงอยูหน้าต่าง Options ให้ทาการกาหนดค่าต่างๆตามรู ป เสร็ จแล้วให้คลิกปุ่ ม OK
       ั ่                                                                ้
ตอนนี้ยงอยูหน้าต่าง Options เช่นเดิม ให้ทาการกาหนดค่าต่างๆตามรู ป (ยังไม่ตองคลิกปุ่ ม OK)




เริ่ มทาการสร้างโปรเจ็คใหม่ โดยคลิกที่ File -> New -> Project...
ตอนนี้จะมีหน้าต่าง New Project ปรากฎขึ้นมา ให้ทาการกาหนดค่าต่างๆตามรู ป เสร็ จแล้วให้คลิกปุ่ ม OK
ที่หน้าต่าง Win32 Application Wizard คลิกปุ่ ม Next > เพื่อดาเนินการต่อ




ขั้นตอนสุ ดท้าย ให้ทาการกาหนดค่าต่างๆตามรู ป เสร็ จแล้วให้คลิกปุ่ ม Finish
กลับมาที่หน้าต่างหลักของ Visual C++ 2008 ให้คลิกที่ Project -> Properties...
ตอนนี้จะมีหน้าต่าง ชื่อProject Property Pages ปรากฎขึ้นมา ให้ทาการกาหนดค่าต่างๆตามรู ป
                                     ้
เสร็ จแล้วให้คลิกปุ่ ม Apply (ยังไม่ตองคลิกปุ่ ม OK)




ที่หน้าต่าง FirstProject Property Pages เช่นเดิม ให้ทาการกาหนดค่าต่างๆตามรู ป เสร็ จแล้วให้คลิกปุ่ ม OK
กลับมาที่ Dialog ให้นาปุ่ ม Button มาวางบน Dialog แล้วแก้ไขตามรู ป
จากนั้น ดับเบิ้ลคลิกที่ OpenPicture แล้วให้ทาการเขียนโปรแกรมตามนี้
    ้
ที่ดานบนสุ ด #Include ตามรู ป
ที่ void   CPictureDlg::OnBnClickedOpenpic()                    ใส่ Code ตามด้านล่าง

void CPictureDlg::OnBnClickedOpenpic()
{
                          ั                           ่                ้      ่
           //โหลดรู ปใส่ ตวแปร Pic ในวงเล็บเป็ นที่อยูของไฟล์ และ ไฟล์ตองมีอยูจริ ง
           IplImage* Pic = cvLoadImage("C:\\Park Bom.jpg");

           //สร้าง Window ชื่อ Picture ขนาด Auto Size
           cvNamedWindow("Picture",1);

           //นารู ปในตัวแปร Pic มาแสดงที่ Window ชื่อ Picture
           cvShowImage("Picture",Pic);

           //รอให้มีการกดปุ่ ม
           cvWaitKey(0);

           //ปิ ดหน้าต่าง Picture
           cvDestroyWindow("Picture");

}




เมื่อเขียนโปรแกรมเสร็ จเรี ยบร้อยแล้วให้ทาการ Build โดยคลิกที่ Build -> Build Solution
                                                                 ่
ที่หน้าต่าง Output จะรายงานผลของการ Build ออกมา ตรงนี้ให้สังเกตุวาจะต้องเป็ น 0 failed
ถ้าไม่ใช่แสดงว่ามีบางอย่างผิดพลาดให้ทาการตรวจสอบแก้ไขโปรแกรมที่เขียน




ทาการรันโปรแกรมที่เขียนขึ้น โดยคลิกที่ Debug -> Start Debugging หรื อกด F5
หากไม่มีอะไรผิดพลาด จะได้ผลออกมาตามรู ป
                                                      ์
หากต้องการปิ ดหน้าต่างการแสดงผล ให้กดปุ่ มใดๆบนคียบอร์ ด
การติดตั้ง OpenCV สาหรับ VC2008



                  เสนอ
         อาจารย์ ธนัญ       เรื อนคง




               จัดทาโดย
      นาย นัฐพล ทัศนคง 49087307




คณะสารสนเทศศาสตร์ ภาควิชาวิศวกรรมคอมพิวเตอร์
            ปี การศึกษา 2/2552

				
DOCUMENT INFO
Shared By:
Categories:
Tags: OpenCV
Stats:
views:263
posted:5/29/2012
language:Thai
pages:23
Description: OpenCV ถูกพัฒนาขึ้นเพื่อใช้เป็นเครื่องมือสำหรับนักพัฒนาโปรแกรมทางด้าน Image Processing และ Computer Vision