tech support problems _ solutions

Document Sample
tech support problems _ solutions Powered By Docstoc
					Tech Support Problems and Solutions
C:\Docstoc\Working\pdf\[e80c52c6-d155-454d-b814-bad548fa9c2f.xls]Sheet1
Customer on old version



                    Problem
message 19 logon screen error, or, www-status
shows "message 12" error (instead of the word
"processing")




how check if coldstart has flashconnect auto startup


compile a program
logon seems to work but as soon as you do
something it asks you to logon again
common error - line 3 mismatch - www-continue

check if flashconnect is available

www-start or www-status does not work on new
account

How to start flashconnect with manager


How to shutdown flashconnect and the manager
(www-shutdown)

How to start flashconnect (www-start)


How to shutdown flashconnect

check flashconnect version


check D3 version
flash compile a WPB program


Socket error or No Slots error when do www-status




Locking problem, Record locked and need to
unlock.




Locking problem




Error
"" is an illegal command
(nothing runs on fc, even runtable, p2logon, etc).
w3Pipe::StartRead()



Click on any button (any cgi request) and system
browser just spins.
Inconsistant workspace




Browswer shows "Status: 500 Sorry, no
FlashCONNECT servers are available at this time.
Try again in a few moments. -1" or "http 500 Internal
Server Error…"




www-status shows "no license" when try to start
flashconnect.
System is slow or stuck or hung




Schedule is not working/started. "where" should
show:
129 000825 BF10 000018 P PP_SCHED:000
"z who" - submits job and the list-jobs showed
queued.
List-jobs shows queued jobs.
Restore vme




Entering monitor debugger...
Unrecognized Opcode @ WRAPUP_SUB:000
Unrecognized Opcode @ PX_RESUME:000
invalid password.
ipx load
(May see these errors when tandem flashconnect
port or on www-status).
Or… Any monitor debugger errors...
Invalid account password, please contact the site
administrator
How to to interupt: fcdebug -t


super q pointer, osfi network-status connection lost.




How interput network-status?

How reset printer spooler?
GL is out of balance, can not update invoices.




w3Input: Read did not complete


Browser shows "Status: 500 w3Pipe::StartRead()
ERROR_PIPE_NOT_CONNECTED, possible
Flash/NonFlash compile mismatch 233"


Browser version and settings. Logon problems,
wrong /previous header data displaying, etc.

Packslip not printting detail line items for order


"Page can't be displayed error" on new install.


File Inconsistency Encountered - Incorrect Count
Field
Q=Quit/O=Logoff/S=Skip/F=Fix/T=Truncate/<CR>=
Debug?
Get logon page, but won't logon. Just goes back to
logon page.


Action canceled error when print to screen. When
try to do from abba office does not work but works
fine at customer site and customer is using port
other than 80 on netpartner.
Status: 500 w3ErrLog::ActuallyOpen()
RegisterEventSource() failed 5




www-status shows db.getbuf
Break key in telnet not working

Stops in www-continue at tocall
500 error




Change ar check date.
Did cash receipt (or deposit) on an order, but now
showing up in ar#34, (Cust. Performance Inq)




Invoice does not show in cash receipts or customer
inquiry (does show in cust perform inq)
In order entry, cash receipt is not showing, but
shows on customer perform inquiry (ar#34).
cash receipts record missing on cash register report
but invoice paid off correctly on ar#34 & 32.

invoice: paid entire invoice amt, but still balance due
showing. (view using ar#38)
Invoice data wrong. Due=0 (ard<24>) or invoice
amount wrong or gross amount wrong.. Invoice
update hung but then went thru 2nd time.




When logon to green screen port and go to menu,
displaying funny characters on screen for tabs.
Popup’s not working



Invoice incorrect, want to credit off and then not see
either on books. (bad invoice)


gld out of balance




update gl trans says out of balance yet gld 9 is in
balance.
Trial balance (which uses glh) is wrong (but gld is
correct). (Posting to wrong account)




Bad payroll check (print to wrong printer, etc.)

Printted payroll to wrong printter and said yes to
‘successful’.
po receipts didn’t not seems to update inventory.
No inventory transaction written.
Backup didn’t go thru.

printed ap checks and updated but checks are
wrong.



How to un-void a voided check:




If manual apcheck, but didn't go thru and apd is
open:
How change reference number on a direct journal
entry.
Get ‘0’ when use send options (formsprint) to reprint
invoice, etc.
ed note give ‘Access protected’ error.
Want to backup all accounts except one.



Get “Content-type: text/html Pragma: no-cache Set-
Cookie: w3ProfileId=138476028839762;
expires=Wednesday, 6-Dec-2006 23:59:59 GMT; “
on screen for a split second.
Can not upload to ftp site.

m for master menu not working.
Remote desktop gives the error “…no termial server
license…”




How to copy a file


How to change HP III serial to parallel
procedure for D3/NT patch.




Cannot stop the D3 from services

Linix Netpartner System Slow.
[82] Your system privilege level is not sufficient for
this statement.


after VME restore and QS.UPD command, the
accounts are asking for password

to remove an account's password
cannot compile EBP files after system upgrade




Why don't Hyperlinks in Outlook/Outlook Express
open a new window



How to start D3PDEBUG
http://mail.abbasoft.com:8000 not working, but
regular email is ok.


how to restore MDS from the tape
4-bad548fa9c2f.xls]Sheet1
            (7/5/04 sm) per Jim, If customer is more than 1 release back, they must upgrade before we
            can help with Netpartner problems (Note: for partner, multiplie releases back is ok). (ex: if
            19.2, 20.1, 20.2, then if customer on 19.2, they must upgrade).

                                                       Solution
            Logon to www account
            Copy w3messages (O
            To: (fsi:dm,messages,
            and
            copy w3messages (o
            (dm,messages
            then, stop & restart flashconnect lines.
            go to dm account
            type "ED MD USER-COLDSTART"
            Check if there is "www-manager start" or "www-start ….."
            logon to accountname, compile bp programname (o
            check bp w3402 size
            check w3syscon company 17 (timeout flag) set to 28800
            Not all program are flashcompiled. Recompile all program. Use utility to make sure some
            don't get skipped.
            logon to dm
            sysid
            Make sure account in flashenabled (www, m, 8)
            Make sure 8 files (wbp, w3Groups, w3Html, w3Logs, w3Logs.control, w3Users, W3APPS,
            w3Lines) are q pointed to www
            Go to www account
            type 'M' to go to flashconnect menu
            type 1 to start flashconnect

            1. Go to www account, type 'M' to go to flashconnect menu, type 2 to shutdown flashconnect
            2. or www-shutdown
            Go to www account
            type "www-start #of_process_to_start IP_address port_number"
            ex: www-start 5 209.80.42.2 505
            Go to www account
            type "www-shutdown"
            go to www account
            type 'M' to go to flashconnect menu
            type 9 to check flashconnect version
            go to TCL
            type "which cd"
logon to accountname,
SELECT DICT WBP WITH A1 = "CC" AND WITH 0 = "program name" compile wbp
programname (ow
1. Do a www-shutdown and then www-start ...
2. If this does not help do a www-shutdown (f
3. Check w3config on www account to see what the IP number.
4. If the D3 server and Web Server are two different machines, check to see if both server are
talking to each other. (hints: open an MS Dos Prompt on D3 server and type "ping WebServer
IP address")
5. If this does not help reboot the server with flashconnect NT on it. (the web server). The
problem is the two machines are not communicating correctly.
Using Green Screen:
  1. Go to TCL prompt
  2. "list-locks" to see locks
   a. "clear-locks" to clear all locks (simplest option)
   b. "item-unlock filename record" to clear 1 lock
       (Note, this won't work with an fsi lock).
  3. "clear-file w3abbalocks" to free all abba locks
Using Netpartner:
  1. Go to the "EZ Processor" Moules (shortcut = "w3")
  2. Select "Display locks" under the maintenance dropdown.
  3. Enter "y" under 'clear' or 'logoff' and click save to clear lock.
There are now 2 new programs to display the Phantom Locks and clear them if needed.

To display the Locks from TCL enter DISPLAY-LOCKS
You will see all the FSI Locks and if it is a Phantom lock you will also
see the date and time it was locked

If you want to clear the phantom locks from TCL enter
CLEAR-PHANTOM-LOCKS
It will display all the locks and then ask you if you want to clear
them. You can clear all or 1 lock only.

There is a multi-value in a hidden field. Need to get rid of this.
stop flashconnect and restart (www-shutdown, www-start …)

If a flashconnect bp start's executing and then either the pipe is terminated ( by someone
doing a www-stop) or the program stop's (error's out) w/o returning smoothly, this this error
will occur. Need to tandem the port and trace which bp is being called and fix the bug.
1. Check www-status and see if any ports in debugger or hung.
2. Check locks.
3. Check www-status index number starts with 0, 1, 2, etc. and no ports are down, compare to
c:\program files\flashconnect\fcdebug -t and make sure count is the same. If not, www-
shutdown and restart the fcservce.
Check listu and stop any flashconnect port that was started from dm and restart in real
account (ex: dev). Make sure coldstart does not start flashconnect, this will always start in dm
account causing this problem when you run a report. (the select statement to lptr crashes it).
Also, set term in coldstart before starting flashconnect ports. ex: TERM 79,25,0,1,1,8,132,59
1. Flashconnect ports not started. (or wrong address or port#)
2. All flashconnect ports currently being used. Check www-status and see if all ports are
being using (processing).
3. If there are free ports but still getting a 500 error, this means fc service could have a bad
port connection to d3. Check fcdebug -t on the webserver and check if any ports are bad.
The user may have gotton the port that is not working. To fix, must restart fcservice (or entire
webserver) (If you can't view fcdebug -t, look at the index number on www-status, If you are
running only one host, the numbers should be 0 to x, if missing numbers, then there could be
a bad fc service port).

No enough users. Check maxusers.

If system slow check:
1. Www-status to see if ports hung, if so bplistlog to find cause, then tandem and break port.
2. Clear-jobs then list-jobs to see if locks are tying up system. If locks are older than a few
minutes make sure monitor-locks running, check w3abbalocks. Tandem and break locks if
needed. Should have clear-jobs in the coldstart!
3. List-locks. Check for locks in phantom ports.
4. Phantom-status to see if out of phantom's
5. Fcdebug to see if sessions stuck in "waitd3" and not counting down. If so, must stop and
restart fcservice.
6. list-users
7. w to see if and sys abort's or other problems.
8. Check nt processer and memory and tasks. Check cpu process, see if at 100% a lot.
9. Is problem just on client or on server.
10. Check files are sized correctly. (Especially w3html) (use file-sizer in dm account)
11. Reboot server, periodically (every 1-2 weeks). This helps with nt memory leakage and d3
flash shared memory space.
12. Check for viruses on server (and client)
1. Clear-file jobs (if lots of queued junk)
2. Stopsched
3. Startsched 129 (i (assuming phantom-status stops at 128).
3a. If line 129 not available logoff if it's a junk process.
4. Try "z who" and make sure on list-jobs that's is done.
5. Check "where" or "where z" to make sure schedule is ok.
6. If this does not work restart d3. (or reboot)
6a. (before reboot) select jobs with status = "q]" delete jobs.
Must restore vme if: change ports, phantoms, overflow or size.
1. Select mds with a1 = "qs""QS"
2. Save-list vme1
3. Get-list vme1
4. Delete mds
5. Set-device
6. File-save
7. Shutdown
8.d3 device manager -> resize vme -> update -> exit
9. Stop d3odbc, set d3 & d3odbc to manual in services.
10. reboot
11. copy disk0.d3v to d3virtual from /i386/win32 (skip if 7.2)
12. open dos and in d3programs do: d3vme /restore
13. select device, file reallocation=n, resotre from incre.=n
14. telnet localhost
15. set d3odbc and d3 to previous settings in services.

Flash memory error. Need to reboot d3 to cleanup memory and get patch.
Check flash memroy on server to see if full and/or showing errors.
(In general, must reboot nt about once a week to avoid these problems).
(Try 'shutdown', if problem, stop service, if problems, just reboot).
Check registery setting:
my computers\hkey_local_machine\sotware\rainingdata\d3\currentversino\flashbasic
         SegmentBase “0”
Add it in if missing.
If get this error when try any http command to the flashconnect account, then: w3apps <5> is
pointing to wrong account. Use w3#5 to fix.
waitsession - Normal, open port, waiting for user to click on browser.
waitd3 - User clicked something on browser and now waiting for d3 to respond.

If using network-setup for super q pointer to connect to a file over the internet and having
problems with losing the connection, try changing the remote host trasmit timeout from default
15 to a higher number (ex: 50).
(2/5/03) Pick says should be on D3 version 7.2.1 or above if having problems.

Abba Server ----> Beach Server (from abba, can read beach files)
  network-setup must be setup & running on beach server. If problems with connection,
  check network-status and make sure running and open ports available.
Network-status is the file cache. This lists the opened cached files that have been access
thru that port. If you log off the port and back on, this reset's the cache.
startspooler (i      i=initialize
To check:
 select gld with a9 # ""
 sum gld 9               - should come out to zero.

Solution:
  1. There may be a gld with a missing gl#, check if atr 8 is null for any gld record. If so, put in
a appropriate (or junk) gl#.
 2. Next, check all periods are same (atr 1 and 2)
 3. Next check atr 8 are all same length (usually 8)
This means there was a w3input to get info from the user (ex: a call ut165) which never came
back. Either it timed out, or the user closed the window or went to another screen w/o
answering. (Or browser window already closed and tried to call ut165).
1. Problem with compiled programs. First restart w3lines as this often clears it up. If not, if
upgraded flashconnect version or changed where www accont is or w3apps; may have to
recompile some (or all) programs.
2. Can be problem with flashconnect lines not working correctly because scheduler not
running. Type 'w' and check last port is running ppsched.
Must use Internet Explorer version 6.0 or newer (as of 1/1/04). Under tools, internet options,
settings, must have 'check for newer versions of stored pages' set to 'every visit to page'.
Must have cookie enabled. Must have javascript enabled.
Check ordd atr 9 has non-zero values. If order status was 'open' instead of 'open(o)' this
could cause the problem. To fix, use order status, change status to 'cancel'; then if ord 29 is
'open', set to 'open(o), then print packslip again.
If can view /cgi-bin/ indexed dir., but when click on fccgi.exe says "page can't be displayed"
then it's a permissions err. In iis, web server ext. make sure to allow isapi, and unknown cgi
programs (iis 6.0)


Copy file data to another file. Delete file. Recreate.
If don't know file, do file-save. Can use 'T' to truncate to fix data, but will lose data.

Problem with d3 not reading cookie (thus profileid comming in blank in w3abbaall) because
not set correctly on client computer. To verify, click 'version' and see if profileid is changing
everytime go to this page. Solution: try setting privacy to lowest level 'accept all cookies'. (?)

Need to setup a second netpartner website on iis using the specific port#. (Setup all standard
directories including cgi-bin, javascript, etc). Point the router port to this port number (instead
of port 80).
Raining data say problem writing to eventlog. But this is not true, it seems to be a problem
related to running out of active flashconnect ports (or something simular). Try putting on
monitor program to keep flashconnect ports alive…
* Need to check if last flashconnect port hit recently. If so, try adding more fc ports to avoid
error.
(sm 5/1/06) This bug is duplicatable if you call link with null hostname ex: "&w3hostname="
?
set-break 28 (for ctrl \) set-break 03 (for ctrl-c) (can put in coldstart after logto account).
Better to set in d3 settings on server.
recomiple bp's (if doesn't help, try wbp also)
1. Check if last port being hit. If so, probably need more ports.
2. Turn off friendly message on browser to get more specific error message.


Use ute#34. Old solution: ed archk cust#*check# atr <1>. May change ar<34> and gl files as
needed, but not too important if in same period. (Use new table under netpartner, ute).
If archk exists and is fine, can manually add data into ard record.
 Update ard:
  <24> = ar balance
  <25> = cash paid (md2) (mv)
  <42> = date paid (mv)
  <43> = paid amt (md2) (mv)
  <84> = archk# (mv)


Manually add to ar<38>.

add archk record to ord<93>. Select archk with 3 = [invoice# from cust. perform inquiry]

Probably put wrong rec.date on cash receipts. Check archk atr 1 is correct (use ute2#34 to
fix).

Check ard 5+6+7+8 = 25+26+27. Then can manually fix ard<24> = 0 (balance due)
Reset ordd 3,4,9. qty shipped <3> = ‘’, qty back <4> = x, qty to ship <9> = x. Delete ard, cord
and cordd. Set ord status to shipped (or picked) and create shp file. Set ord<53> to ‘p’ if
already set to ‘u’. Then go thru ship confirm and invoice update again. Note: This will re-
deduct from inv qoh. This may create a new different invoice number, even if ord<52> is
already assigned !
Solution2: Can manually update amounts on ard if need (ex: 5,17,24,83)


ed ezloc port#, set <4> to vt100g.
Turn off popup blocker. (if ie, check under tool). If can’t figure it out.
1. sent screen shot to us.
2. send help email so we can connect to your computer.

Do credit memo. Or use oed#37 for auto credit memo, then close the new order. (Then
modify both ard records and zero out atr 5,6,7,8,9,17,24,83. System does not normally zero
out invoices, this is only for speical problems).

To check: (run bp check.gld or gld#30)
 select gld with a9 # ""
 sum gld 9               - should come out to zero.

Solution:
  1. There may be a gld with a missing gl#, check if atr 8 is null for any gld record. If so, put in
a appropriate (or junk) gl#. Select gld with a8 # “”
 2. Next, check all periods are same (atr 1 and 2) select gld with *a1 # “04”
 3. Next check atr 8 are all same length (usually 8) select gld with a8 # “^^^^^^^^”
 4. sort gld by 6 break-on 6 total 9 det-supp
 ex: REFERENCE NO AMOUNT
     ============            ==========
       153356                  0.00
       21243                   0.00
       26                     -659.69
 select gld with 6 = "26" ;* since ref. 26 out of balance error is in there somewhere.
 sort gld 3 7 8 desc total 9 (p
 Customer needs to find numeric error out of list printted. Abba can't determine.


Bad gl#, (see gl41l line 256).
Once find incorrect glh posting, can delete glh & fix references to it: (or can have customer do
journal entry to correct account).
To Fix:
 1. delete glh 001*1471317
 2. ed ca 001*00000301*05 - change period 1 value by -38.46
 <1> -74437207 => -74441053
 3. glh.xref 001*00000301*01*05 - remove 001*1471317

list pre-check. If bad record here, delete and then start at pr#32 again (calc payroll, print
checks)
To be able to reprint using same numbers – clear-file pre-check, clear-file pre-earn. Then
reprint.
Check if went to receiving inspection instead. (po#76). Otherwise check it#80, check po#80.
Check po#75. Can do manual inventory adjustment for missing inventory.
Do find on syscon for ‘rebuild’ to make sure something like ‘running rebuild on port 2’ not
causing it to not run.
If want to totally reset as if never printted: void the checks, delete gld records with 5 = today
and with ref a6 = check#’s, delete apcheck records, fix syscon next.check.nbr
 1. Select apcheck with *a1 = internal_date
 2. …

How to un-void a voided check:
1. delete 2 gld records with 'apvc' and matching ref# to check#.
2. delete apcheck (ex: vh20043)
3. update apd <22> to null. (void check#)
4. Update
apd<14> check date -> insert date
apd<16> check number -> insert ap check#
apd<52> gl# check -> insert gl#
apd<55> status -> change to ‘paid’
apd<37> payoff period month -> insert period
apd<38> payoff period year -> insert period
apd<40> total paid -> insert amount
apcheck<4> check flag -> change to 0

ex: select gld with 7 = “apvc” and with 6 = “check#”
Note: This is basically a ‘hack’ and does not fully update all apd records correctly as ap406
does.
 Should usually tell customer no option to unvoid a check. Or make billable.


remove apcheck, gld entries, redu the manual apcheck
This is saved in gl.activity. If <25> # ‘y’ (then not updated) and can copy gl.activity to new id
(since ref# is in id). If 25=y (then updated), must change record and fix gld.

Either form wrong (check syscon and forms) or known invoice reprint bug.
ed dict md note (d and remove everything after line 3.
ed mds account_name
Change <1> from qs to q. Change back after backup.
If linux, ‘ed mds account_name (d’ change <1> d to dx.


This is because one page was posted (such as a redirect or ending page). Then the driver
posted a 2nd page starting with “content-type…”. You need to set id<2> = “postedclosing” so
the driver does not post the 2nd page.

Add user to security in iis ftp propertis. In exploer, add user to directory security &allow write.
Copy dict ebp task from a working account.
The computer accessing the terminal server is actually the client issued the license. There
are scripts out there that have been written that will renew the Terminal service license to
resolve this issue. Here is what I have done, and it has worked without a problem on every
PC I have used it on:

The Process of automating this on the affected client machine (not server), is this:

do this from the client machine, not already connected to the remote server…
get http://www.thereservesnetwork.com/licensing.exe (or
u:/_shared/vendor_software/microsoft termial service)
click OPEN or RUN
click UNZIP then OK then CLOSE
reboot (or just click start > programs > startup > licensing) then, the error will not come back

at tcl
>COPY filename (OI
option I suppresses display of item-ids
option O overwrites duplicate item-ids
off line the printer
hold MENU for 5 second
select serial or parallel option on the menu. The selected option is marked with *
1. download the patch file '.exe'
2.shutdown d3 and set the services to manual
3.reboot NT
4.execute the '.exe' file
5.start D3
6.from dm account at TCL run this command;
  >COPY DOS:. NT_UPGRADE (O
   TO:(MD
 > NT_UPGRADE
From command prompt on the D3 directory try :
D3VME /stop
D3VME /kill
Clear the file runtime-errors. Clear jobs file. Run nightly process to clear temp netpartner
files.
ed users dev
<8> = sys2
error on d3 program in DM account. To remove the password edit MDS
record and remove line #7. To fix the problem follow these steps:
>ED DM,BP, QS.UPD
insert line 148 : QS=""
>ED FSI:MDS,, account_name (d
remove line #7 password
re-compile the program file CC.BP ( note : regular compile, not flash compile)
add the 'o' to the MD of the COMPILE
re-compile all the EBP's

1.) Open Internet Explorer
2.) Click the Tools menu
3.) Click Internet Options from the Tools menu
4.) Select the Advanced Tab
5.) Scroll down to find the "Reuse windows for launching shortcuts" in the Browsing category
6.) Uncheck the box
7.) Click Ok
1) get the d3vme process id from task manager
2) open up a dos session and make sure that you're on the correct directory path under
d3programs
3)type D3PDEBUG followed by d3vme process id

On email server, make sure the service "ntmail configuration server" is running.
sel-restore MDS (n
(f)ull, ……….
file # : 2

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:5
posted:5/12/2012
language:English
pages:20