open office

Document Sample
open office Powered By Docstoc
					        Creating and Uploading a Webpage with
                  OpenOffice Writer
        • Getting started
        • Creating your webpage
        • Uploading your webpage to
          ALEX!




____________________________________________________
                             45
Getting Started: Creating a Teacher Webpage on
ALEX
  1. Create a new folder on your Desktop by clicking your right mouse button, scrolling
     down to New, and clicking on Folder. (You will be placing all of your Teacher
     Webpage content in this folder.) To rename the folder, right mouse click on the
     folder and select rename, type name.




  2. Title your new folder using your first or last name and “web,” for example,
     csmithweb.



                   Note: When naming folders associated with your
                    webpage, do not use any capital letters, spaces,
                 underscores, dashes, numbers, or any other symbols.

  3. Open this folder and create new subfolders inside this folder. (right click on your
     mouse, scroll to New, and select Folder.) Name the first folder tabone. You will need
     to create a new subfolder for each tab/webpage you create - tabtwo, tabthree,
     tabfour, etc.




____________________________________________________
                                           46
  4. Open Open Office and design your first webpage, (You will be saving this document as
     both a Open Office document and as a filtered webpage.)



           IMPORTANT: Any images you include in your document (other
          than clipart) and any PowerPoints, Excel spreadsheets, videos,
            or Word documents that you link to in this document must be
             saved in the corresponding tabʼs folder. For example, if you
         create a hyperlink to a PowerPoint or insert a picture of your class
            on your first webpage (tabone), then you will need to save the
          image and/or PowerPoint in the tabone folder. Save the images
            and documents in the appropriate folder first. Then, insert the
                    images or create a hyperlink to the document.




                Note: When naming folders associated with your
                 webpage, do not use any capital letters, spaces,
              underscores, dashes, numbers, or any other symbols.



____________________________________________________
                                          47
  5. Save and Name your Document
     • Choose File→Save As.
     • In the Save in: window, Browse to find your webpage folder on your desktop and
       double-click folder to open it.
     • Then, double-click on the folder tabone.
     • File name: Name your file with a single word (or phrase
      with no spaces) that indicates its role in your webpage, i.e. homepage,
     calendar, schedule, or homework.


                Note: When naming folders associated with your
                 webpage, do not use any capital letters, spaces,
              underscores, dashes, numbers, or any other symbols.




                            homepage




     • Click: Save.




____________________________________________________
                                          48
OpenOffice Writer 2.3.1

Using OpenOffice Writer with the ALEX webpage feature


Opening a Writer Document
1. At your Desktop click start.
2. Choose All Programs from the menu.
3. Choose OpenOffice.org 2.3 from the program menu.
4. Choose OpenOffice.org Writer.


Writer Toolbar
Your Writer Toolbar is very similar to the toolbar in the Microsoft Word software. To
activate any of the following functions simply click the button pertaining to the function you
wish to use.

                                                                  Print and Print
                                     Send        Export to        Preview            Spell Check
                    Open a           Document    PDF File
       Create New   Saved            as Email
       Document     Document




                               Font Name        Font Size    Bold, Italicize, and
                                                             Underline Text         Left, Center, Right,   Font Color, Highlight
                                                                                    and Justified          Text, and Background
                                                                                    Alignment              Color




You can also access the font style, font size, and alignment icons by clicking your right
mouse button.


____________________________________________________
                                                                   49
Undo your last action or restore a deleted action using your toolbar
       1. Clicking the blue arrow pointing to the left in your toolbar will undo your last action.
       2. Clicking the blue arrow pointing to the right in your toolbar will restore the last
           action your previous action.




Undo your last action using the Edit menu
       1. Select Edit from the menu bar.
       2. You will see the “Undo” feature at the top
           of the drop-down menu. The phrase that
           follows “Undo” is determined by your last
           action, i.e. delete typing, etc.




Copy – Cut – Paste
    1. Highlight the text you want to copy.
    2. Hold down the left mouse button and slide the mouse to where

      you want to stop copying and let go of the mouse button.
    3. If you wish to copy the text choose the Copy icon from your toolbar.
    4. If you wish to cut the text choose the Cut icon from your toolbar.




        Copy                                  Cut                                 Paste


____________________________________________________
                                               50
  5. After you have either cut or copied your text you can paste it into another area of the
     document by placing your cursor where you want the text to appear and clicking the
     Paste icon in your toolbar.
  6. You can also Copy, Cut, and Paste by using your right mouse button.
  7. After highlighting an area of text, click your right mouse button and you will see a drop
     down menu containing the same cut, copy, and paste icons.


Spell Checking
  1. Your SpellCheck icon appears in your toolbar at the top of the
     screen. When you click this icon, OpenOffice begins to review your
     text and alerts you of any misspelled words. If a misspelled word is
     found you will see a box. OpenOffice will suggest an alternate spelling
     for the word and you can either choose to Change the word or Ignore
     the suggestion.




  2. If you have used the word multiple times in the document you can choose to Change
     All and each appearance of the word will be changed or Ignore All and the spell
     checker will ignore any other appearances of the word.




____________________________________________________
                                              51
   3. OpenOffice also has an Auto Spell Check feature. Clicking on
      this icon will allow OpenOffice to check your spelling as you
      type. If it encounters a misspelled word, the software will notify
      you by underlining the word with a red line.


Changing the font, font style, size of the font, color, etc.
   1. In addition to using your toolbar, you can also change your
      font style by using the Format key.
   2. Click Format at the top of your screen.
   3. Choose Font from the drop down menu.
   4. You will see a screen displaying all of the program’s font options: Font, Font Effects,
      Position, and Hyperlinks. This is also available through the dialogue box:




      Select your font, font style, position, hyperlinks, and background, and click ok.
Clip Art
   1. Before placing clipart in your webpage, save the selected clipart into your tab folder, i.e.
      tabone, tabtwo, etc. The best way to insert clipart into your OpenOffice document is to
      find the graphic you wish to use and copy and paste it directly into your document.
   2. After you have done this, you can double click on your graphic to bring up a formatting
      window. This window allows you to resize, crop, position, change colors, and add
      borders to your graphic.

____________________________________________________
                                                52
  3. OpenOffice also offers a Gallery feature. By clicking on the Gallery icon in your
     toolbar you can bring up a listing of different backgrounds, bullets, page dividers, and
     sound icons.


                       Other Images
                       1.To insert other images or pictures into
                       OpenOffice, use the same procedure used for
                       clipart.


                             Note: To insert pictures from the Internet, you must
                              first save the image to your tab folder, i.e. “tabone.”

                       2.To insert pictures from the Internet, you must first save the image to
                       your computer. Right click the image and choose Save Image As….
                                        Choose a file and name for your image and click save.


                                      3. In OpenOffice click Insert in the your toolbar at the
                       top of the screen. Scroll down to Picture and choose From File.


  4. A screen will come up where you can find your picture. When you have found the
      picture, click on it and choose Open.



____________________________________________________
                                              53
Inserting Hyperlinks
  1. Choose and highlight the text that you want to appear as a hyperlink to a web site.
  2. Click Insert at the top of your screen in the toolbar. Choose Hyperlink from the
     drop down menu. A new window will pop up.
  3. Here you can choose your hyperlink.




      Links to Webpages
  1. If you wish to link words in your text to a webpage on the Internet you must create a
     web hyperlink.
  2. Type the address of the webpage that the text will be linked to.
  3. Indicate the text that will serve as the link in the box labeled Text.
  4. You can also give your hyperlink a name by filling in the box labeled Name.
  5. When you have finished filling out the page click Apply.
  6. To access your hyperlink hold down the Ctrl key and click on the link.


  Inserting an Email link
  1. Choose Mail and News from the Hyperlink window.
  2. Enter the email address in the box labeled Receiver.
  3. In the box labeled text, indicate what words you would like the hyperlink to appear as.
  4. Click Apply.
____________________________________________________
                                              54
  Linking to another Document
  1. Choose Document from the hyperlink window.

  2. Click the folder      icon next to the box labeled Path to browse your files.
  3. Choose the file you wish the link to.
  4. In the box labeled Text indicate the text you would like the hyperlink to appear as.
  5. Click Apply.
  6. You can use the same method to link to a new document.


                Note: To insert pictures from the Internet, you must
                 first save the image to your tab folder, i.e. “tabone.”
Tables
  1. To insert a table click Insert from your toolbar at the top of the screen.
                 Note: Tables may also be set up under the “Insert ->
              Indexes and Tables” menu of the toolbar. For the purpose
              of Teacher Webpages, we recommend the “table” option
                                     from the toolbar.
  2. Choose Insert→Table.
  3. You will see a window with options for setting up your table.




  4. First give your table a name.
  5. Choose how many columns and rows you want your table to have.
  6. You can also choose to have a header for your table or a border.
  4. Click OK and your table will be created.



____________________________________________________
                                             55
Formatting your Table
  1. When your table is created a small screen will appear in the upper left hand corner of
       the screen. This is your formatting toolbar.
         Borders




 Line style and Line color




                                                               Merge Cells and Split   Sum
                                                               Cells
                             Insert Row and   Delete Row and
                             Insert Column    Delete Column
  2. To insert an extra row into your table, click the Insert Row button. The row will be
       inserted below the row with your cursor in it.
  3. To delete a row select the row you wish to delete and click Delete Row.
  4. To insert a column click Insert Column. The column will be inserted to the right of
       your cursor.
  5. To delete a column select the column you wish to delete by moving your arrow over the
       top the column and left clicking (the column will be highlighted). Click the Delete
       Column button.
  6. To merge two cells together highlight the cells and click the Merge Cells button.
  7. To split two cells highlight the cells and click the Split Cells button.
  8. The Sum button allows you to use the table to solve mathematical problems.
  9. You can also format your table by highlighting it and clicking your right mouse button.




____________________________________________________
                                                  56
Saving as a Webpage


              Note: Be sure you have saved your OpenOffice document
                before you save as a Webpage as a HTML document.


After saving your OpenOffice document, you must now save the document as a HTML
document (OpenOffice.org Writer) (.html)
    a.
 Choose File → Save As




   b.
 Save in: Browse to the same tab folder where the OpenOffice document is
       stored (i.e., tabone).
   c.
 Save as Type: Choose HTML document (OpenOffice.org Writer)
       (.html)
   d.
 Click Save.




____________________________________________________
                                          57
Uploading your Teacher Webpage_________________
    1. When you have finished creating your webpage and have saved it as a Open Office
       document, go to File → Save As. In the Save window, find the Save as type drop-down
       menu at the bottom of the window. Click on the arrow and choose Webpage,
       Filtered. Make sure you are saving the webpage in the tabone folder. Name your file
       homepage.
       DO NOT CLICK SAVE YET.










                                homepage




    2. Once you have chosen Webpage, Filtered, you will see Page Title appear above the
       File Name. This is the title of your webpage, which will appear at the top of the
       Internet window when someone views your webpage.




____________________________________________________
                                            58
  Click on Change Title. A small window will appear. Type in the title of your webpage and
  click OK. Then, Click Save. A small window will then pop up. Click Yes. Close the file.




  In your tabone folder, you should now see all of your linked images and documents, an Open
  Office document, an HTML document (your webpage), and a folder named tabone_files
  (this folder is automatically created when you save your webpage), i.e. homepage_files.




  3. Repeat steps 1 and 2 for each tab folder, which represents each webpage.


                Note: Each tab folder cannot exceed 8 MB in size.
                 All of your tab folders combined cannot exceed
                                  30 MB in size.




____________________________________________________
                                            59
                    Note: Any time you edit your Open Office
                    document, you must re-save it as a Open
                   Office document and as a Webpage, Filtered.
                   A pop-up window may appear asking if you
                   want to replace the existing file(s). Click Yes.

  4. When you have created all of your webpages, you will need to “zip”, or compress, each
     folder individually to upload them onto ALEX. Right click on the tabone folder, scroll
     down to Send To, and click on Compressed (zipped) Folder. A small window may
     pop up. If so, click Yes to confirm.




  You should now see a zipped file in your main webpage folder called tabone.




  5. Repeat step 4 for each of your tab folders.

                    Note: Any time you edit your Open Office
                  document and HTML file (webpage), you must
                 delete the old ZIP file and re-zip the edited tab
                 folder. This ensures that all of your files include
                                   your changes.

____________________________________________________
                                            60
  6. You are now ready to upload your webpages to ALEX! Go to http://alex.state.al.us. Click
     on Personal Workspace and log in using the username and password you created
     and confirmed at the beginning of this training. Click on Create A Webpage.

  7. You should see a screen that looks like the following:




  Notice that there are only 3 tabs displayed. You can add more tabs by clicking the Add
  button. You can create up to 8 tabs (8 webpages).




  You can also remove tabs by clicking on a tab and clicking the Remove button.

  8. Under Tab Name, type the name of each of your webpages. This will be the text that
     is displayed on each of your webpage tabs. For example, you might name your tabs
     Home, Homework, Class Schedule, and WebQuest Activities.




____________________________________________________
                                             61
  9. You are now ready to upload your webpages! Click the Browse button next to Tab
     Number 1. A File Upload window will appear. Find your webpage folder and double
     click it to open the file. Find the zipped file named tabone. Click on it and click
     Open.




  10. You should now see the file location/path listed in the white box next to the browse
      button. Click Save at the bottom of the screen.

  11. Repeat steps 9 and 10 for each tab.

          Note: You must click Save each time you upload a new file.

  12. When you have finished uploading and saving all of your ZIP files, you can click View
      to see your webpages.




  13. You can now click Submit for Review so that your webpage can be reviewed and
      posted.

____________________________________________________
                                            62