Menu

Document Sample
Menu Powered By Docstoc
					                                                            Perangkat Lunak Aplikasi C




                              Sesi/Perkuliahan ke: IX


Tujuan Instruksional Khusus :
1. Mahasiswa mengerti dan memahami pembuatan Menu


Pokok Bahasan : Menu


Deskripsi singkat : Dalam pertemuan ini akan mempelajari Menjelaskan cara
pembuatan Menu


Referensi :
1.     Peter Norton’s, Guide to Visual Basic 6, SAMS Publishing, 1998
2.     Djoko Pramono, Mudah Menguasai Visual Basic 6, Elex Media Komputindo,
       Jakarta, 1999




Menu                                                                  Halaman 1 dari 5
                                                          Perangkat Lunak Aplikasi C




                                    Menu


Menu merupakan salah satu fasilitas menarik yang ditambahkan pada program
 aplikasi. Sebuah menu dapat berisi item menu, judul submenu, item submenu
dan garis pemisah. Setiap isi menu tersebut berasosiasi dengan kontrol menu
yang dibuat melalui menu editor.


Menu Editor


Dengan menu editor, dapat ditambahkan isi sebuah menu yang sudah ada,
membuat menu baru, atau juga menghapus sebagian isi menu yang sudah jadi.
Untuk menampilkan menu editor, pilih menu Tools          Menu Editor, atau klik
icon   Menu        Editor   pada Toolbar




Membuat Kontrol Menu


Cara membuat kontrol menu dengan menu editor :
1. Pilih Form yang akan diberi menu, lalu tampilkan menu editor.


Menu                                                                Halaman 2 dari 5
                                                            Perangkat Lunak Aplikasi C


2. Pada kotak Caption ketikkan teks yang ingin ditampilkan pada menu.
3. Pada kotak Name, ketikkan nama yang akan digunakan untuk pemanggilan
   kontrol di jendela kode.
4. Tombol panah kiri atau panah kanan dapat digunakan untuk mengubah posisi
   kontrol menu apakah sebagai judul menu, item menu, judul submenu, item
   submenu dan sebagainya.
5. Mengatur properti untuk kontrol menu.
6. Klik Next untuk membuat menu kontrol yang lainnya. Klik Insert untuk
   menyisipkan kontrol menu yang baru diantara kontrol menu yang sudah ada.
   Tombol panah atas atau panah bawah dapat digunakan untuk berpindah
   diantara kontrol-kontrol menu yang terdapat pada kotak daftar.




                                                            Pop-Up Menu




7. Klik OK jika telah selesai bekerja dengan Menu Editor.


Properti pada Menu Editor


Beberapa Properti pada Manu Editor yaitu :
1. Checked : Bila properti ini diberi tanda check maka pada menu yang telah
   dibuat setelah dijalankan akan terlihat tanda check yang artinya menu
   tersebut sedang aktif.
2. Enabled : Bila properti ini di nonaktifkan maka menu yang dibuat setelah
   dijalankan tidak dapat di klik atau nonaktif.




Menu                                                                  Halaman 3 dari 5
                                                           Perangkat Lunak Aplikasi C


3. Visible : Bila properti ini dinonaktifkan maka menu yang dibuat setelah
   dijalankan tidak akan tampak pada layout.
4. Windowlist : Properti ini digunakan pada aplikasi yang menggunakan MDI
   form. Kegunaan windowlist ini adalah untuk menampilkan childform-childform
   yang telah dibuka.




Membuat Pop-Up Menu


Pop-Up menu adalah menu yang ditampilkan di atas form dan terpisah dari
menu bar. Lokasi pemunculan menu bergantung dari tempat menekan tombol
mouse.
Untuk membuat Pop-Up menu, Visual Basic telah menyediakan metode yaitu
PopUpMenu.


           [Objek.] PopupMenu namamenu [,flags [,x[,y[, bold]]]]




Menu                                                                 Halaman 4 dari 5
                                                         Perangkat Lunak Aplikasi C


Multiple Document Interface (MDI)


MDI adalah salah satu fasilitas Visual Basic, yang memungkinkan pemrogram
 untuk membuat sejumlah form di dalam sebuah form induk. Program yang
dibuat dengan Visual Basic hanya dapat memakai satu buah form MDI. Form
MDI tersebut dapat menampung form-form lain yang tidak terbatas jumlahnya.
Form yang ada di dalam sebuah form MDI biasa disebut dengan childform.


Menggunakan Form MDI


1. Untuk membuat Form MDI pilih menu Project, kemudian pilih Add MDI Form.
2. Untuk membuat child form, pilih menu Project, kemudian pilih Add Form. Atau
   membuka form yang sudah ada. Lalu atur properti MDIChild dari form
   tersebut bernilai True.




Menu                                                               Halaman 5 dari 5

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:1
posted:3/4/2012
language:
pages:5