Docstoc

cisco_a_e command mappings

Document Sample
cisco_a_e command mappings Powered By Docstoc
					Function
Lab 2.1a
clear startup config
reboot the system
reboot system with new config file
turn on lldp
show lldp neighboring devices
show cdp neighboring devices
set to snmp version 2c
define snmp ro community name
define snmp rw community name
define snmp traps source address
enable unauthenticated telnet service
save running config to nvram
save running config to flash
specify startup config as file in flash
confirm non-default startup config file
show files in flash
show config in ram
show config in nvram
to end a telnet session from the target
to generate a key pair
to create a local user
specify access channel for a local user
set line password login for a line
to set local username login for a line
to set line to require no authentication at all
to enable ssh
to launch telnet client
to launch ssh client
to disable telnet server
to view oubound telnet sessions
to disconnect an outbound telnet session
to view inbound telnet sessions
to disconnect an inbound telnet connection
to view inbound ssh sessions

Lab 3.1a
to create vlans 11, 12, and 13
list vlans
create trunks
specify vlans to be carried by a trunk
verify vlan-to-trunk assignments
set port to access mode
configure ip address on an interface
configure ip helper-address on an int
verify configured dhcp relay server group
verify vlans on which dhcp relay is enabled
configure dhcp server
additional configurarable dhcp values
enable gvrp globally
enable gvrp on a particular interface
view gvrp status
view gvrp status on a particular int & vlan

Lab 4.1
activate mstp
view spanning tree info
view mstp configuration info
to verify port role and root port path cost
to set stp port path cost standard to dot1t
to set all ports to be edge ports by default
to make an exception to the edge port def
to set a port to be an rstp edge port
to set a port to be an rstp non-edge port
configure mst region name and revision
configure mst region instances and activate
view spanning tree mst configuration
show mst ist
to view short list of mst instances and port roles
configure mst bridge priority for mst ist instance
configure mst bridge priority for non-ist mst instance
set config file to a file in flash
confirm config file that device will load upon restart
to verify cisco rapid-pvst vlan bridge priority settings
to set pvst mode on cisco switches

Lab 6.1
to disable stp on a specific int
to re-enable stp on a specific int
to create a smart-link group
to verify smart-link group configuration
create a monitor-link group
to verify a monitor-link group configuration
display stp root bridges

Lab 7.1
to set a port as an edge port
set bpduguard
set bpduguard recovery and recovery interval
to verify errdisabled ports
to enable hp e-series loop protect on individual ports
to set loopguard or loop protect disable timer
enable e-series hp loop protect to generate logging
to verify hp loop protect configuration
to enable hp a-series loop protect globally & on vlans
to enable hp a-series loop protect on specific ports
to display up/down status of all ports plus ip configuration
to display quick summary of ip config
show short list of lldp neighbors
show detailed information for a specific lldp neighbor
to create vlan
to place an access mode port into a particular vlan
to set a particular vlan to be carried on a vlan trunk
to configure an ip address on a vlan interface
enable rootguard on a particular interface
to verify spanning tree root bridge

Lab 8.1
To enable logging to the serial console session
To enable logging to a telnet or ssh console session
create a port trunk
configure port trunk as a vlan trunk
enable port group member interfaces
verify port trunk status

Lab 9.1
to save running config to a new file in flash
to set startup config file
to create an hsrp standby group
to create a vrrp standby group
to verify current vlan trunk interfaces

Lab 10.1
to reset to factory default config
give device a hostname
enable lldp
verify lldp status
set telnet access, no authentication, privileged mode
to save configuration to a specific file
to set a specific startup config file
return to privileged level promt (no config level)
to enable ip routing
acl implicit final statement
start an ospf routing process
verify ospf neighbors
verify interfaces activated for ospf
show networks learned via ospf

Lab 10.2
to configure redistribution between two ospf processes
view contents of log buffer
to receive status messages in a serial console session
to receive status messages in an ssl or telnet session



to terminate an ssh or telnet session

MODULE 2
display password in config in encrypted form
specify time sync protocol
specify ntp server
set local timezone name and offset from UTC
set DST parameters
enable logging in general
to synchronize typed input with session logging messages
specify syslog server
specify syslog message severity level
to enable logging to be seen in current session
specify level of messages logged to the console
enable logging to internal buffer and level of messages sent
view contents of onboard logging buffer
to view current configuration of logging on the system
include timestamping with logged messages
define a local user
specify local authentication
enable snmpv2
enable snmpv3
specify source address for snmp traps sent
enable sending of snmp traps
specify snmpv2c trap receiver
specify snmpv3 trap receiver
suppress sending of link up/down snmp trap on an interface
suppress sending of link up/down snmp trap globally
define snmpv3 engine ID (for authentication purposes?)
define and snmpv3 group
create an snmpv3 user
define informative snmp server location
define informative snmp server contact info
define an snmp read, write, or notify view

enable lldp globally
enable lldp on a specific interface
enable lldp on a-series for cisco phone compatibility
view basic lldp info for all neighbors
view detailed lldp info for all neighbors
view detailed lldp info for a specific neighbor
view cdp neighbor info

MODULE 3
create a vlan
set dot1q encapsulation
set interface to trunk mode
set untagged vlan for trunk
remove untagged vlan for a trunk
configure vlans allowed on trunk
add a vlan to a trunk
remove a vlan from a trunk
set interface to access mode
set access mode vlan
view which ints are connnected, speed, duplex, whether a trunk or access port
view vlan related administrative and operational details of an interface
view which vlans are allowed and actually active on a trunk
configure an ip address on a vlan interface
set a default-gateway for a non-routing switch
set a gateway of last resort on a routing switch
view interfaces with configured ip addressing
configure a helper address on a vlan int to enable access to a dhcp server
create a hybrid interface
create a tagged vlan on a hybrid interface
create an untagged vlan on a hybrid interface
designate a pvid vlan on a hybrid interface
remove default pvid from a hybrid interface
specify a hybrid port tagged vlan as a voice vlan
Cisco

erase startup-config
reload
n/a
lldp run
sh lldp neigh
sh cdp neigh

snmp-server community public ro
snmp-server community private rw
snmp-server source-interface int
line vty 0 4, no login, priv level 15
wr mem
copy run flash:filename
boot config flash:filename
show boot config
show flash
sh run
sh star
exit
crypto key generate rsa usage-keys mod 1024
username netadmin priv level password netadmin
n/a
line <con 0 | vty 04>, login
line <con 0 | vty 04>, login local
line <con 0 | vty 0 4> no login
ip ssh ver 2
telnet 1.2.3.4
ssh 1.2.3.4
line vty 0 4, transport input ssh
sh sessions
disconnect <line_num>
sh users
clear line <num>
show ssh



vlan 11-13
sh vlan brief
swi trunk encap dot1q, swi mode trunk
swi trunk allowed vlan 1,11-13
sh int trunk
int ra g1/0/10-12, swi mode access, swi access vlan 11
int vlan 11, ip addr 10.2.1.1 255.255.255.0
int vlan 11, ip helper-address 10.2.1.3
n/a
sh run int vlan 11
ip dhcp pool mypool, network 4.4.4.0 /24,
dns-server 4.4.4.100, default-router 4.4.4.1, exit, ip dhcp excluded-address 4.1.1.1 4.1.1.9
n/a
n/a
n/a
n/a



spanning-tree mode mst
sh spanning-tree
sh spanning-tree mst configuration
sh spanning-tree
spann path-cost method long
spanning-tree portfast default
int g1/0/1, no spanning-tree portfast
int g1/0/1, spanning-tree portfast

spann mst config, name HP-Cisco,
 inst1 vlan 12, inst 2 vlan 1,11,13 ,exit
sh spann mst configuration
show spanning-tree mst 0
n/a
spann mst 0 pri 4096
spann mst 1 pri 4096
boot config flash:interop-5a.cfg
sh boot
sh spann vlan 1, sh spann v 11, sh spann v12, sh spann v13
spann mode pvst




n/a



int g1/0/2, spann portfast
spann bpduguard enable
errdis recovery cause bpduguard, errdis recovery interval 30
show int status err-disabled




sh ip int brief
sh ip int brief, sh ip protocols
sh lldp neighbors
sh lldp entry case_sensitive_hostname
vlan 200
int g1/0/3, switchport mode access, swi access vlan 200
int g1/0/1, swi mode trunk, switchport trunk allowed vlan 100
int vlan 200, ip addr 10.2.200.1 255.255.255.0
int g1/0/3, spann guard root
sh spann root


logging console (enabled by default)
terminal monitor, logging monitor ***CHECK THIS***
int p2, int ra g1/0/3-4, shut, channel-gr 1 mode active
int p2, swi trunk encap dot-1, swi mode trunk
int ra g1/0/3-4, no shut
show lacp neighbors, sh etherchannel summ


copy run flash:filename
boot config flash:filename
int vlan 1, standby 1 ip 10.2.1.254, standby 1 pri 200
n/a
sh int trunk, sh int switchport



wr erase, reload
config t, hostname Cisco-A
lldp run
sh lldp interface
line vty 0 4, privilege level 15, no login
copy run flash:interop-10a.cfg
boot config flash:interop-10a.cfg, show boot config
return
ip routing (enabled by default)
deny any
router ospf 1, router-id 2.1.1.1, netw 10.0.0.0 0.255.255.255.area 0
sh ip ospf neighbors
sh ip ospf int brief
sh ip route ospf



router ospf 1, redistr ospf2 subnets metric 100
show logging
logging console
logging monitor, terminal monitor




service password-encryption
n/a
ntp server 1.2.3.4 [prefer]
clock timezone pdt -8
clock summer-time PDT recurr last sun mar 2:00 last sun oct 2:00 60
logging on
line <con 0 | vty 0 4>, logging synchronous
logging host 1.2.3.4
logging trap <0-7>
terminal monitor
logging console <0-7>
logging buffered level
sh logging
sh logging
service timestamps log datetime [localtime]
username netadmin priv 15 password some_password
line <con 0 | vty 0 4>, login local



snmp-server source-interface trap loopback 0
snmp-server enable traps
snmp-server host 1.2.3.4 verstion 2c community_name
snmp-server host 1.2.3.4 version 3 auth snmpv3_user
int s0/0/1, no snmp trap link-status
n/a
snmp-server engineid local ABCD123456
snmp-server group admin3group v3 <auth | priv | noauth> …
snmp-server user clara3 admin3group v3 auth sha authpass priv aes 128 privpass
snmp-server location "some descriptive string "
snmp-server contact "some descriptive string "
snmp-server view view_name subtree_specification <included | excluded>

lldp run
lldp enable
lldp complance cdp, int g1/0/1, lldp compliance admin-status cdp txrx
sh lldp neighbor
sh lldp neighbor detail
sh lldp entry neighbor_hostname
sh cdp neighbor



vlan 100,111-115
switchport trunk encap dot1q
switchport mode trunk
switchport trunk native vlan 99
n/a
switchport trunk allowed vlan 99,100, 200-203
switchport trunk allow vlan add 105
switchport trunk allow vlan except 105
switchport mode access
switchport access vlan 100
sh interface status
sh interface f0/2 switchport
sh interface f0/2 trunk
int vlan 99, ip addr 10.1.1.2 255.255.255.0
ip default-gateway 10.1.1.1
ip routing, ip route 0.0.0.0 0.0.0.0 192.168.1.1
sh ip int brief
int vlan 100, ip helper-address 172.16.1.1
n/a
n/a
n/a
n/a
n/a
n/a
A-Series

reset saved-config
reboot
n/a
lldp enable
dis lldp neighbor-information list
n/a
snmp-agent version v2c
snmp-agent community read private
snmp-agent community write publie
snmp-agent trap-source int
telnet server ena, user-int vty 0 4, authent mode none, user priv level 3
save
save filename .cfg
startup saved filename .cfg
display startup
dir /all
dis curr
dis startup
quit
public-key local create rsa
local-user admin123, password <cipher | plaintext> password, authorization-attribute level level
local-user admin123, service-type [ssh] [telnet] [ terminal]
user-interface vty 0 4, authentication-mode password
user-interface vty 0 4, authentication-mode scheme
user-interface vty 0 4, authentication-mode none ***console always allows unauthenticated access?***
ssh server enable
telnet 1.2.3.4
ssh2 1.2.3.4
undo telnet server enable
?
?
sh users
?
display ssh server



vlan 11 to 13
display vlan
port link-type trunk
port trunk permit vlan all
display vlan 11 to 13
port 10, port link-type access
vlan 11, int vlan 11, ip addr 10.2.1.5 24
dhcp relay server-group 1 ip 10.2.1.3, int vlan 15, dhcp select relay, dhcp relay server-select 1
display dhcp relay server-group 1
display dhcp relay all
dhcp enable, dhcp server ip-pool vlan2-pool, netw 10.2.11.0 24, gateway-list 10.2.11.254, expired day 0 hour 2,
dns-list 10.2.1.100, domain-name example02.hp.com, dhcp server forbidden-ip 10.2.11.1 10.2.11.101
gvrp
int g1/0/1, gvrp, gvrp reistration normal
display gvrp status
display gvrp state int g1/01 vlan 100



stp enable
display stp, display stp brief
display stp region-configuration
display stp, display stp root
stp pathcost-standard dot1t
port-group manual EdgePorts, group-member g1/0/1 to g1/0/24, stp edged-port enable
int g1/0/1, stp edged-port disable
int g1/0/1, stp edged-port enable
undo edged-port enable
stp region-configuration, region-name HP-Cisco, revision-level 1,
 inst 1 vlan 12, inst 2 vlan 1 11 13, active region-config
display stp region-configuration
display spanning-tree instance 0
display stp brief
stp inst 0 priority 4096
stp inst 1 priority 4096
startup saved interop-5a.cfg
display startup
n/a
n/a



int g1/0/1, stp disable
int g1/0/1, stp enable
smart-link group 1, protected-vlan reference-inst 0 to 1, preemption mode role, port g1/0/1 master, port g1/0/2 slave
display smart-link group 1, or display smart-link group all
monitor-link group 1, port g1/0/1 uplink, port g1/0/3 downlink
display monitor-link group 1, or display monitor-link group all
display stp root



int g1/0/3, stp edged-port enable
stp bpdu-protection
n/a




loopback-detection enable, loopback-detection enable vlan all
int g1/0/2 loopback-detection enable
display brief int
display ip int brief
display lldp neighbor-information brief, dis lldp neigh list
display lldp neighbor-information int g1/0/2
vlan 200
int g1/0/3, port link-type access, port access vlan 200
int g1/0/1, port link-type trunk, port trunk permit vlan 100
int vlan 200, ip addr 10.2.200.3 24

display stp root



terminal monitor

int bridge-agg 3, link-aggr mode dynamic, int g1/0/1, port link-agg group 3,int g2/0/1, port link-agg group 3
int bridge-agg 4, port link-type trunk, port trunk permit vlan all
n/a
display link-aggregation verbose


save filename
startup saved-config filename
n/a

display port trunk



undo startup saved-config, reboot
sys, sysname HP-C
lldp enable (enabled by default)
display lldp status
telnet server enable, user-interface vty 0 4, authentication-mode none, user privilege level 3
save interop-10a.cfg
startup saved-config interop-10a.cfg, display startup
end
***ALWAYS ON - RIGHT???
permit any
ospf 1 router-id 2.3.3.3, area 0, network 10.0.0.0 0.255.255.255
display ospf peer
display ospf int
display ip routing-table protocol ospf



ospf 1, import-route ospf 2 cost 100
display logbuffer reverse | i <search_criteria >
terminal monitor
terminal monitor
reset saved, reboot

ctrl-k




n/a
ntp-service unicast-server 1.2.3.4 [priority]
clock timezone PST <add | minus> 08:00:00
clock summer-time PDT repeating 02:00 2011 mar last sun 02:00 2011 oct last sun 01:00
info-center enable
info-center synchronous
info-center loghost 1.2.3.4
info-center source default channel loghost <trap | debug | log> level level [log level level ] [debug level level ]
<hp> terminal monitor
info-cednter source default channel console log level level
???
display logbuffer [reverse]
display info-center




snmp-agent trap source loopback 0
snmp-agent trap enable
snmp-agent target-host trap address udp-domain 1.2.3.4 udp-port 162 params securityname public v2
snmp-agent target-host trap address udp-domain 1.2.3.4 udp-port 162 params securityname public v3
int g1/0/1, undo enable log updown
undo snmp-agent trap enable standard [linkup] [linkdown]
snmp-agent, snmp-agent sys-info version v3
snmp-agent group v3 admin3group ...
snmp-agent usm-user v3 clara3 admin3group [authentication-mode sha authkey ] [privacy-mode aes128 privkey ]
snmp-agent sys-info location "some descriptive string"
snmp-agent sys-info contact "some descriptive string"
snmp mib-view <included | excluded> view_name subtree_name

lldp enable
???
n/a
display lldp neighbor-information list
display lldp neighbor-information list
display lldp neighbor-information int g1/0/1
n/a



vlan 50, vlan 60, vlan 100 to 110
n/a
port link-type trunk
port trunk pvid vlan 99 (***when vlan 1 is the pvid, it will not show in the config - there is no default pvid***)
undo port trunk pvid
port trunk permit vlan 100 104 106 to 110
port trunk permit vlan 103
undo port trunk permit vlan 103
port link-type access
int g1/0/1, port access vlan 100 *or* vlan 100, port g1/0/1 to g1/0/24




int vlan 99, ip addr 10.1.1.2 24

ip route-static 0.0.0.0 0 10.1.1.1
display ip int brief

port link-type hybrid
port hybrid vlan 200 untagged (***when a hybrid port is created, vlan 1 is automatically untagged on it by default***)
port hybrid vlan 100 tagged
port hybrid pvid vlan 200
undo hybrid pvid vlan 1
voice vlan 100 enable
E-Series

erase startup
reload
boot
lldp run
sh lldp info rem
n/a

snmp-server community public operator unrestricted
snmp-server community private manager unrestricted
snmp-server trap-source 1.2.3.4
defaults to unauthenticated access at manager access level
wr mem
copy config config1 config interop-2a.cfg
startup-default config interop-2a.cfg
show config files
show config files
sh run
sh star
exit
crypto key generate ssh rsa
password <operator | manager> user-name admin plaintext password




ip ssh
telnet 1.2.3.4 ***right?***
n/a
no telnet
?
?
sh telnet
?
?



vlan 11, vlan 12, vlan 13
sh vlan
n/a
vlan 11, tagged 1-2, vlan 12, tagged 1-2, vlan 13, tagged 1-2, vlan 1 untagged 1-2
sh vlan 11, sh vlan 12, sh vlan 13
vlan 11, untagg 10-12
vlan 11, ip addr 10.2.1.5/24
vlan 15, ip helper-address 10.2.1.3
???
???
***
***
gvrp
default enables gvrp on all interfaces when enabled globally
sh gvrp
?



spanning-tree
sh spanning-tree
sh spanning-tree mst-config
sh spanning-tree
n/a
spanning-tree 1-24 auto-edge-port



no spann 1-2 auto-edge port, no spann 1-2 admin-edge-port
spann config-name HP-Cisco, spann config-rev 1,
spann inst 1 vlan 12, spann inst 2 vlan 1 11 13, spann pending apply
sh spanning-tree mst-config
sh spanning-tree instance ist
n/a
spann pri 1 (meaning 1 * 4096)
spann inst 1 pri 1 (meaning 1 * 4096)
rename config source_file dest_file , startup-default config dest_file
sh config files
n/a
n/a




n/a



spann 3 admin-edge-port
spann 3-24 bpdu-protection
spann bpdu-protection-timeout 30

loop-protect 2-3
loop-protect disable-timer 30
loop-protect trap loop-detected
show loop-protect



sh int brief
sh ip
sh lldp info rem

vlan 200
vlan 200, untagged 3
vlan 100, tagged 1
vlan 200, ip addr 10.2.200.5/24

sh spann, sh spann root-history <ist | msti instance_num >



debug destination session (refers to current session via any protocol)
debug destination session (refers to current session via any protocol)
int 1-2 disable, trunk 1-2 trk1 lacp
int trk1, vlan 11 tagged trk1, vlan 12 tagged trk1, vlan 13 tagged trk1
int 1-2 enable
show trunk, show lacp
n/a

sh vlan 11 (look for interfaces tagged for this vlan) ***SOMETHING BETTER?



erase startup, (enter y at prompt to reboot)
config t, hostname HP-E
lldp run (enabled by default)
sh lldp config
***ENABLED BY DEFAULT???

wr mem, rename config interop9a interop10a
end
ip routing
deny any
ip router-id 2.5.5.5, router ospf, aria 1, valn 100, ip ospf area 1
sh ip ospf neigh
sh ip ospf int
sh ip route ospf



n/a
???
debug destination session (refers to current session via any protocol), debug events
debug destination session (refers to current session via any protocol), debug events
erase startup (will automatically reboot)

logout



include-credentials
timesync <sntp | timep>, sntp unicast
sntp server pri <1-3 > 1.2.3.4
time timezone 480 daylight-savings PDT
time timezone -480 daylight-time-rule continental-us-and-canada



logging server 1.2.3.4
logging severity level   ***applies globally?***
debug destination logging (applies globally)

debug destination buffer

???




no snmp-server communicty public, snmpv3 enable, snmp3 restricted access (???)

snmp-server trap-source vlan 1
???
snmp-server host 1.2.3.4 public all
n/a???
no snmp-server enable traps link-change 1-46
no snmp-server enable traps link-change all

snmpv3 group managerpriv user clara3 sec-model ver 3
snmpv3 user clara3 auth sha authpass priv aes privpass
snmp-server location "some descriptive string "
snmp-server contact "some descriptive string "



lldp run
lldp enable
n/a
show lldp info rem
show lldp info rem all
sh lldp info remote port_id
sh cdp neighbor

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:2
posted:2/14/2012
language:English
pages:16