IDM+crack ????????????????????

Document Sample
IDM+crack ???????????????????? Powered By Docstoc
					                                                                            คู่มืออบรม Adobe Flash CS3



                                           ิ
                       คู่มืออบรมเชิงปฏิบัตการ การสร้างสื่อด้วย Adobe Flash CS3

วัตถุประสงค์

         1.    รู้จักหลักการสร้าง การ์ตูน Animation จาก Flash CS3
         2.    ใช้เครื่องมือในการวาดและสร้าง Animation ได้
         3.    สามารถใช้ Basic Action Script ได้
         4.    ได้สื่อ Animation อย่างน้อย 1 คลิป
         5.    ผู้เรียนสามารถนาไปประยุกต์ใช้ในการสร้างสื่อในภายหน้าได้เอง

รู้จักกับโปรแกรม Flash

ประวัติความเป็นมาของ Adobe Flash CS3

Adobe Flash
          Adobe Flash ชื่อเดิมคือ Shockwave Flash และ Macromedia Flash
เป็นโปรแกรมที่ใช้ในการเขียนสื่อมัลติมีเดียที่เอาไว้ใช้สร้างเนื้อหาเกี่ยว กับ Flash ซึ่งตัว Flash Player
                                ิ
พัฒนาและเผยแพร่โดย อะโดบีซสเต็มส์ เริ่มต้นพัฒนาโดยบริษัท ฟิวเจอร์แวร์ ตอนหลังเปลี่ยนเป็น แมโครมีเดีย
ซึ่งภายหลังถูกควบรวมกิจการเข้ากับ อะโดบี ซึ่งเป็นโปรแกรมที่ทาให้ เว็บเบราว์เซอร์ สามารถแสดงตัวมันได้
ซึ่งมันมีความสามารถในการรองรับ ภาพแบบเวกเตอร์ และ ภาพแบบแรสเตอร์
และมีภาษาสคริปต์ที่เอาไว้ใช้เขียนโดยเฉพาะเรียกว่า ActionScript และยังสามารถเล่นเสียงและวีดิโอ
แบบสเตริโอได้


          จุดเริ่มต้นจริง ๆ ของโปรแกรม Flash จริง ๆ ก็ไม่ได้อยู่ที่บริษัท Macromedia หรอกครับ โดยในปลายปี
                            ื่
1995 มีบริษัทเล็กๆ ที่ชอว่า Future Splash ได้พัฒนาโปรแกรมที่ชื่อ Future Splashขึ้นมาเพื่อใช้สร้าง
                                                                                 ่
ภาพเคลื่อนไหว (Animation) แบบ Vector Graphic สาหรับนาไปใช้งานในเว็บเพจ ซึงมีข้อดีคือไฟล์ภาพแบบ
                                 ่
Vector นั้นมีข้อมูลที่เล็กมาก เมือนาเอามาใช้สร้างเป็นภาพ Animation แล้วนาไปใช้แสดงในหน้าเว็บเพจ แล้ว
จะใช้เวลาในการโหลดข้อมูลที่เร็วกว่าภาพ Animation GIF แบบเดิม ๆ มาก
                                                                             คู่มืออบรม Adobe Flash CS3




          ทางด้านบริษัท Macromedia ในเวลานั้นมีโปรแกรม Macromedia Director
เป็นตัวชูโรงของโปรแกรมสาหรับสร้างงาน Animation และ Multimedia อยู่ โดยได้พัฒนา Plug-In ที่ชื่อว่า
Shockwave Director ขึ้นมาเพื่อให้งาน Animation หรือ Multimedia ที่พัฒนาขึ้นมาโดยโปรแกรม Director
สามารถนาเอาไปเล่นในเว็บเพจได้แต่ก็ไม่ประสบความสาเร็จเท่าที่ควร
          เพราะไฟล์โปรเจ็คเตอร์ที่ได้จากโปรแกรม Director นั้นมีขนาดใหญ่เกินกว่า ที่จะนาเอาไปใช้งานได้จริง ๆ
                                                                  ่
(แสดงผลในเว็บเพจได้อย่างรวดเร็ว) ในยุคที่ความเร็วอินเทอร์เน็ตยังตาอยู่มากเมื่อเทียบกับสมัยนี ้
                                                                               คู่มืออบรม Adobe Flash CS3



         ดังนั้นในปี 1996 บริษัท Macromedia ก็เลยซื้อกิจการของ Future Splash
ไปเป็นส่วนหนึ่งของกิจการตัวเอง โปรแกรม Future Splash จึงถูกนามาพัฒนาผสมผสานกับ Shockwave
Director ที่มีอยู่เดิม จนพัฒนาออกมา เป็นโปรแกรม Flash (Flash2) ขึ้นมา และได้พัฒนาออกเรื่อย ๆ




                                                                                                     ้
           ในปี 2005 บริษัท Adobe ทุ่มเงิน 3.4 พันล้านเหรียญสหรัฐซื้อกิจการของบริษัท Macromedia ดังนัน
                                                               ่
เมื่อถึง Flash 9 ตัวล่าสุดในปัจจุบัน โปรแกรม Flash จึงถูกห้อยชือ CS3 ตามท้ายเพื่อให้เข้าชุดกับบรรดา
โปรแกรมพี่น้องร่วมค่าย Adobe ตัวอื่น ๆ นั่นเอง




                                                   ้
          Adobe Flash ถูกพัฒนามาอย่างต่อเนื่องตังแต่เวอร์ชั่น 3, 4, 5, MX, MX2004, 8, CS3 ซึ่งรุ่นล่าสุดคือ
                                ่
รุ่น CS4 ซึ่งมีการเปลี่ยนแปลงเพือให้เข้าชุดกับโปรแกรมกราฟฟิกอื่น ๆ ของ Adobe Flash CS3
เป็นโปรแกรมสร้างงาน , Multimedia , Animation และสื่อการสอน ได้อย่างง่ายและดีที่สุดอีกโปรแกรมหนึ่ง
สามารถสร้างผลงานได้หลายรูปแบบ ตามความต้องการของผู้ใช้งาน
และยังสามารถเขียนคาสั่งควบคุมการทางานต่างๆ ของ Animation ได้อีกด้วย
(หน้าจอโปรแกรม Flash CS3)
                                                                          คู่มืออบรม Adobe Flash CS3




ความต้องการของโปรแกรม
- หน่วยประมวลผล Intel Pentium 4, Intel Centrino, Intel Xeon, หรือ Intel Core™ Duo (หรือเข้ากันได้)
- Microsoft Windows XP พร้อมด้วย Service Pack 2 หรือ Windows Vista™ Home Premium, Business,
   Ultimate, หรือ Enterprise (ได้รับการรับรองสาหรับรุ่น 32-bit)
- หน่วยความจา 512 MB (แนะนาที่ 1 GB)
           ่                                      ่ ่                       ้
- เนื้อที่วางในฮาร์ดดิสก์ 2.5 GB (ต้องการเนื้อที่วางเพิมเติมขณะที่ทาการติดตัง)
- ความละเอียดหน้าจอ 1,024x768 พร้อมด้วยการ์ดวิดีโอ 16-bit
- ไดร์ฟดีวีดีรอม
- ต้องการโปรแกรม QuickTime 7.1.2 , DirectX 9 สาหรับคุณสมบัติด้าน Multimedia


                                                เมนูบาร์
                               คู่มืออบรม Adobe Flash CS3




                                             พาเนล
                                             ต่าง ๆ




Tool




       Properties Inspectter
คู่มืออบรม Adobe Flash CS3
                                                                        คู่มืออบรม Adobe Flash CS3



การตั้งค่าก่อนการใช้งาน




          จะเปดไฟลใหมขึ้นมาจากนั้นเราจะตองตั้งคากอนการทางานโดยเลือกที่คาสั่ง Modify >Document
จะปรากฏ หนาตาง Document Properties ขึ้นมาใหกาหนดคากอนการใชงาน สิ่งที่ควรรูคือขนาดความกวาง
และความสูงของ งาน, Frame rate,และหนวยวัด
          Dimensions คือขนาดของสเตจที่ใชใน การแสดงมูฟวี่ ซึ่งสามารถกาหนดไดหลายวิธี ใสความกวาง
และความสูงในชอง width และ hight ซึ่งถาหากไมระบุหนวย โปรแกรมจะใช หนวยตามไมบรรทัด
ขนาดมาตรฐานของ
สเตจคือ 550-400 พิกเซล ขนาดเล็กสุดคือ1*1 พิกเซล และขนาดใหญที่สุดเทากับ 2880*2880 พิกเซล
          Match : Printer เปนการกาหนดขนาด สเตจใหเทากับพื้นที่ใหญที่สุดที่สามารถพิมพได ซึ่ง
                                                       ่
คานวณจากขนาดกระดาษลบดวยพื้นที่ขอบ โดยรอบ ตามทีกาหนดไวในสวนของPage Setup
          Match : Contents เปนการกาหนด ขนาดสเตจ โดยปรับใหมีพื้นที่รอบๆ เนื้อหาทั้งหมดเทากันในแนวตั้ง
และแนวนอน โดยพื้นที่วางดานขวาจะถูกปรับให เทากับพื้นที่วางดานซาย สวนพื้นที่วางดานลางจะถูกปรับให้
                                                          ้
เทากับพื้นที่ดานบน ดังนั้นถาตองการใหสเตจมีขนาดพอดี กับเนือหาจะตองเลื่อนองคประกอบทั้งหมดไปชิดมุม
ดานซายบนกอนคลิกปุมนี้
          Match : Default ใชปรับขนาดสเตจใหเทากับคา มาตรฐานคือ 550*400 พิกเซล
          Frame rateจะถูกตั้งมาใหที่ 12 เฟรมตอวินาที
                               ่
ถาหากตองการภาพเคลื่อนไหวทีราบลื่นยิ่งขึ้นใหเปลี่ยนตัว เลขใหมากๆ
ถาหากตองการนาไปใชกับงานวิดีโอใหตั้งคาเปน 25 เฟรมตอวินาที
                                                                            คู่มืออบรม Adobe Flash CS3



          Ruler units คือหนวยวัดโดยจะมีใหเลือกทั้ง Pixel, Inches, Points, Centimeters,และ Millimeters
       ้                                ุ
เมื่อตังคาตางๆ ตามตองการแลวใหคลิกที่ปม OK ก็จะพรอมสาหรับสรางสรรคงาน

สวนประกอบที่สาคัญของ Adobe Flash CS3

         สวนประกอบสาคัญที่ตองใชงานMenu bar / Stage / Toolbox / Timeline(Frame&Layer) / Properties
                                                                                      ่
/ Panel / Library/Action เหลานี้เปนสวนที่จะไดใชบอยๆ จึงจาเปนที่จะตองทาความรูจักวาใชเพือทาอะไร
                                                           ่
         Menu bar หรือ แถบเมนู ประกอบดวยเมนูคาสั่งตางๆ ทีใชในการสรางมูฟวี,่ การจัดการกับไฟล และ
วินโดวโปรแกรม รวมถึงการตั้งคาพื้นฐานตาง ๆ



                                                         ่
          Stage คือพื้นที่สี่เหลี่ยมสีขาวตรงกลาง หนาจอ ซึงเราใชสาหรับจัดวางเนื้อหาของมูฟวี่ แตละ
                                                    ั
เฟรมลงไป หรือเปรียบเทียบไดกับสวนหนาของเวทีที่ตว ละครตางๆ จะปรากฏออกมาใหผูชมเห็นนั่นเอง เมื่อ
เลนมูฟวี่ภาพจะปรากฎเฉพาะสิ่งที่อยูบนสเตจเทานั้น สาหรับบริเวณสีเทาโดยรอบสเตจเรียกวา
พื้นที่ทางาน (Pasteboard) เปนสวนที่ใชจัดเตรียมเนื้อหา หรือวางองคประกอบที่ยังไมตองการแสดงใหเห็นเปรียบ
ไดกับดานขางและดานหลังของเวที ที่ตัวละครใชแตงกายหรือเตรียมปรากฎตัว โดยปกติโปรแกรมจะแสดงสวนของ
Pasteboard ไวเสมอ คุณสามารถเปดหรือปดบริเวณนี้ไดดวย คาสั่งView > Pasteboard (Ctrl+Shift+W)
                                                                             คู่มืออบรม Adobe Flash CS3




      ั
ฟังก์ชนการทางานของ Adobe Flash CS3

แถบเครื่องมือหลัก (Main Toolbar)
        แถบเครื่องมือควบคุมการทางานหลักของโปรแกรม เช่น การสร้างไฟล์ใหม่ ,
การเปิดไฟล์,การคัดลอกข้อมูล เป็นต้น โดยสามารถควบคุมให้แสดงหรือไม่ต้องแสดงโดยคลิกเลือกคาสั่งWindow,
Toolbars, Main




แถบเครื่องมือ (Toolbox)
          กลุ่มเครื่องมือสร้างงานและจัดการวัตถุ ประกอบด้วยปุ่มเครื่องมือย่อยต่างๆ สามารถเปิด/ปิดด้วยคาสั่ง
Window, Tools โดยสามารถแบ่งเครื่องมือเป็นหมวดๆ ได้ 5 หมวด คือ เครื่องมือหมวดเลือกวัตถุ (Selection)
เครื่องมือหมวดวาดภาพ (Drawing) เครื่องมือจัดแต่งวัตถุ (Modify) เครื่องมือควบคุมมุมมอง (View)
                            และเครื่องมือควบคุมสี (Color)
                                                                            คู่มืออบรม Adobe Flash CS3




                                 ี
ดังนั้นขนาดของ Stage ควรกาหนดให้มความกว้าง ความสูงสัมพันธ์กับเลย์เอาท์ของหน้าเว็บ

Document Tab(Toolbox)
                                    ส่วนควบคุมเอกสาร สามารถคลิกเพื่อสลับเปลี่ยนจอภาพเอกสาร



Timeline & Layer(Toolbox)
                                                                             ่
Timeline เป็นส่วนสาคัญที่ทาหน้าที่ควบคุมการนาเสนอผลงาน สามารถเปิด/ปิดด้วยคาสัง Window, Timeline




Layer ส่วนควบคุมการสร้างชั้นวัตถุ เพื่อให้การควบคุมวัตถุแต่ละชิ้น มีอิสระ และสะดวกต่อการแก้ไข ปรับแต่ง




                                                                                            Stage &
                                                                                            Workspace
                                                                         คู่มืออบรม Adobe Flash CS3




         จากรูปตัวอย่างนี้ เมื่อสั่งนาเสนอผลงาน แสดงว่าจะกาหนดให้เรือยังไม่ต้องแสดงผลทันทีบนจอภาพ
                                ่                                                         ่
เพราะเรือถูกนาไปวางไว้ในพื้นทีสีเทา เมื่อนามาทาเป็น Movie ให้เรือวิ่งผ่านจอภาพไปอีกด้านหนึง
               ่
ก็จะปรากฏเรือวิงผ่านจอจากด้านซ้ายไปด้านขวาของจอ ตามช่วงเวลาที่กาหนด

Panel
หน้าต่างเล็กๆ ที่ทาหน้าที่แสดงคาสั่งควบคุมย่อยต่างๆ ของโปรแกรม โดยจะปรากฏรายการคาสั่งในเมนู Window
                                                                          คู่มืออบรม Adobe Flash CS3




ควบคุม Panel
         Panel เป็นจอภาพเล็กๆ ที่แสดงฟังก์ชันการทางานเฉพาะอย่าง เช่น การทางานเกี่ยวกับสีจะควบคุมด้วย
                                                      ่
Color Mixer หรือ Color Swatches การจัดตาแหน่งวัตถุตางๆ ควบคุมด้วย Align Panel เป็นต้น
การเรียกใช้หรือเปิด/ปิด Panel จะใช้คาสั่ง Window แล้วตามด้วยชื่อ Panel นั้นๆ

ทางานกับไฟล์ Flash
                                                         ่
           โปรแกรม Flash สามารถสร้างผลงานได้ทั้งภาพนิง ที่เรียกว่า (Still Image) และภาพเคลื่อนไหว
ซึ่งจะเรียกว่า Movie ทั้งภาพนิ่ง และภาพเคลื่อนไหว จาเป็นต้องเริ่มต้นจากไฟล์Flash ต้นฉบับ
ที่มีส่วนขยายเป็น .fla จากนั้นจึงบันทึกเป็นไฟล์ภาพใช้งาน สาหรับภาพนิ่ง สามารถเลือกบันทึกได้หลายฟอร์แมต
เช่น




                                                                       ั
ภาพเคลื่อนไหว หรือ Flash Movie สามารถบันทึกในฟอร์แมตที่พร้อมใช้งาน ได้ดงนี้
                                                                           คู่มืออบรม Adobe Flash CS3




ทางานกับ Stage
                                                                        ่
         Stage เป็นชื่อเรียกพื้นที่สร้างภาพกราฟิกของ Flash นับเป็นพื้นทีสาคัญในการสร้างสรรค์งานกราฟิก
หรือสร้าง Movie มีลักษณะเป็นพื้นที่สี่เหลี่ยมสีขาวล้อมด้วยกรอบสีเทา ภาพกราฟิกหรือวัตถุใดๆ
สามารถวางได้บนพื้นที่สีขาว และสีเทา แต่เมื่อสั่งนาเสนอผลงาน
                            ี่
เฉพาะภาพกราฟิกหรือวัตถุทวางบนพื้นที่สีขาวเท่านั้น ที่จะแสดงผล

ขนาดของ Stage
                                      ้
          ขนาด ของ Stage จะหมายถึงพืนที่การแสดงผลของ Movie นั่นเอง
ดังนั้นก่อนสร้างงานควรกาหนดขนาดของ Stage ให้เหมาะสมและตรงกับการใช้งานจริง
                              ิ
การกาหนดขนาดและคุณสมบัตอื่นๆ ของ Stage ยังสามารถเลือกได้จาก Properties Panel
โดยต้องอยู่ในโหมดการใช้เครื่องมือ Selection

ข้อแนะนาการกาหนดขนาดของ Stage
         วัตถุ ประสงค์หลักของการพัฒนา Flash Movie ก็คือการนาไปใช้เป็นองค์ประกอบของเว็บไซต์
ในปัจจุบันหน้าเว็บไซต์ที่ถือว่าเป็นมาตรฐานจะมีขนาดที่เหมาะสมกับการแสดงบน จอภาพขนาด 1024 x 768
pixels
                                                                             คู่มืออบรม Adobe Flash CS3




                                 ี
ดังนั้นขนาดของ Stage ควรกาหนดให้มความกว้าง ความสูงสัมพันธ์กับเลย์เอาท์ของหน้าเว็บ



ทางานกับสี (Color)
            วัตถุใน Flash จะประกอบด้วยส่วนประกอบอย่างน้อยๆ 2 ส่วน ได้แก่ พื้นของวัตถุ
(Background หรือ Fill) และเส้นขอบวัตถุ (Stroke) แต่ละส่วนสามารถแสดงผลด้วยสีที่แตกต่างกันได้ เช่น
                                                                           ่
รูปสี่เหลี่ยมที่มีเส้นขอบสีดา และพื้นข้างในเป็นสีน้าเงิน ดังนั้นการทางานเกียวกับสี
                       ่
จึงเป็นการทางานทีจะต้องเกี่ยวข้องตลอดเวลา โดยอาศัยชุดเครื่องมือเลือกสี จาก Toolbox




          รายการเลือก No Color จะแสดงผลเมื่อคลิกเลือกวาดสี่เหลี่ยม หรือวาดวงกลม
ดังนั้นก่อนเลือกสีให้กับการวาดสีเ่ หลี่ยม, วงกลม ควรคลิกเลือกเครื่องมือวาดสี่เหลี่ยม
หรือวาดวงกลมก่อนที่จะคลิกปุ่มเลือกสี ซึ่ง เป็นรายการสาคัญมาก และมักจะเป็นรายการทีเ่ ข้าใจผิด เช่น
ถ้าต้องการวาดวงกลมไม่มีสีพื้น หลายๆ ท่าน จะใช้วิธีการเลือก Fill Color ให้กับสีของ Background เช่น ถ้า
                                                                         ่
Background เป็นสีขาว ก็จะเลือก Fill Color เป็นสีขาว ซึ่งมีความหมายที่ตางไป
                                                                             คู่มืออบรม Adobe Flash CS3



คลิกเลือกเครื่องมือ Rectangle สามารถคลิกค้างไว้เพื่อเลือกรูปแบบการวาด




        ื้
กาหนดสีพน, สีเส้นขอบ และลักษณะของเส้นขอบจาก Properties

          นาเมาส์มาคลิก ณ ตาแหน่งที่ต้องการวาดรูป กดปุ่มเมาส์ค้างไว้ แล้วลากเมาส์
เมื่อได้ขนาดและรูปทรงที่ต้องการ จึงปล่อยนิ้วจากเมาส์ ถ้าต้องการรูปที่สมบูรณ์ ควรกดปุ่ม ค้างไว้




ขณะลากเมาส์


Libraryคาสั่งที่ใชเปด/ปด: Windows > Library (Ctrl+L)
                                     ่
         เปนPanelที่ใชจัดเก็บซิมโบลซึงสรางขึ้นภายในโปรแกรมFlashรวมทั้งไฟลชนิดตางๆ
ที่อิมพอรตเขามาจาก ภายนอก ไมวาจะเปนรูปภาพบิทแมพ และเวคเตอรไฟลเสียง และวิดีโอ
เพื่อนามาใชประกับกันเปนมูฟวี่ของFlashเรา สามารถจัดเก็บออบเจ็คเหลานี้อยางเปน
หมวดหมูเพื่อใหสะดวกเวลาเรียกใช
                                                                    คู่มืออบรม Adobe Flash CS3




                                     ่                 ่
          Panel คือกรอบหนาตางเล็กๆ ซึงบรรจุเครื่องมือทีใชสาหรับปรับแตงคุณสมบัติขององคประกอบตางๆ
ในมูฟวี่ ไมวาจะเปนซิมโบล อินสแตนซ เฟรม ซีน ตัวอักษร อื่นๆ รวมทั้งชวยใหเราตรวจสอบคา และจัดการ
เปลี่ยนแปลงองคประกอบเหลานี้ได เครื่องมือตางๆ จะถูกจับแบงไวเปนหมวดหมูในแตละพาเนลตามหนาที่ของมัน
เชน พาเนล Color Mixer ใชสาหรับเลือกสีที่ตองการกาหนดให ออบเจ็คสวนพาเนล Alignใชจัดตาแหนงของ
ออบเจ็ค เปนตน




ภาษาโปรแกรมที่ใช้พัฒนา Adobe Flash CS3

                                                                                        Action
                                                                                        Script
                                                                              คู่มืออบรม Adobe Flash CS3



คาสั่งที่ใช้เปิดปิด : Windows>Action (F9)
           Action Script เป็นภาษาโปรแกรม (Programming language) ที่มีลักษณะเป็น Object - Oriented
Programming ที่ Flash นามาใช้เขียนโปรแกรมเพื่อทาให้ผู้ใช้สามารถโต้ตอบกับ Movie ได้ โดย Action Script
                                                                                 ่
ใช้สาหรับเขียนโปรแกรมเพื่อกาหนดการทางานด้านต่างๆ ซึ่งจะเรียกการทางานนี้วา “Action " โดย Action ต่างๆ นี้
จะขึ้นอยู่กับเหตุการณ์ (Event) ที่เกิดขึ้น หากไม่มเี หตุการณ์ ก็จะไม่เกิดการทางาน (Action)
สาหรับชื่อโปรแกรมนั้นอาจเรียกว่า "โปรแกรม Action Script" แต่โปรแกรมย่อยภายในจะเรียกสั้นๆ ว่า "สคริปต์
(Script)"




พื้นฐานการวาดรูปด้วย Flash
          เมื่อเราวาดรูปดวยเครื่องมือตางๆ ของโปรแกรมFlashสิ่งที่เกิดขึ้นเรียกวา รูปทรง (Shape)
ซึ่งมีองคประกอบ 2 สวน คือ เสน (stroke) และพื้นรูป (fill) ที่สามารถแยกเปนอิสระออกจากกันได




รู้จักกับ Symbol และ Library
          ซิมโบล(Symbol) และอินสแตนซ (Instance)
                                        ่
          ซิมโบล คือ กราฟก ปุม หรือมูฟวีคลิปที่เราสรางขึ้นมาเปน ตนแบบ ในครั้งแรก
จากนั้นก็จะสามารถนาไปใช ไดอยางไมจากัดตลอดในมูฟวี่เดียวกัน และมูฟวี่อื่นๆ ซิมโบลหนึ่งๆ
อาจรวมถึงอารตเวิรคที่นาเขามาจากโปรแกรมอื่น ทุกซิมโบลที่สรางขึ้นจะเปนสวนหนึ่งในไลบรารีของไฟลปจจุบัน
อินสแตนซ คือ สาเนาของซิมโบลที่มีอยูบนสเตจหรือซอนอยูภายในซิมโบลอื่น อินสแตนซอาจมีสี ขนาด และ หนาที่
                                                                      คู่มืออบรม Adobe Flash CS3



แตกตางจากซิมโบลที่เปนตนฉบับไดการแกไขซิมโบลจะมีผลใหเกิดความเปลี่ยนแปลงกับอินสแตนซ
ทั้งหมดที่สาเนาไปจากซิมโบล




                                          การสร้างซิมโบล (Symbol)
            การนาซิมโบลมาใชจะมีผลใหขนาดไฟลมูฟวี่นั้นเล็กลงมาก เนื่องจากการใชอินสแตนซซ้ากันหลายๆ
               ้
ครั้งนั้น ใชพืนพี่นอยกวาการเก็บบันทึกซิมโบลตนแบบหลายๆ ครั้งตัวอยางเชน
คุณสามารถลดขนาดไฟลของมูฟวี่ได
             ่
ถาคุณ เปลียนกราฟก เชน รูปพื้นหลังใหเปนซิมโบลที่สามารถใชไดหลายๆ ครั้งอยางสะดวก นอกจากนั้นการใช
                    ่
ซิมโบล ยังชวย เพิมความเร็วในการแสดงของมูฟวี่ เนื่องจากมีการดาวนโหลดซิมโบลเขามาใน Flash Player
เพียงครั้งเดียว
Symbol มีทั้งหมด 3 ชนิดดังนี้




Movie Clip Symbol : เปนSymbolที่มีการเคลื่อนไหวในตัวเองอยางอิสระ ทางานโดยไมอางอิงความ
                                            ยาวของจานวนเฟรม
                                                                         คู่มืออบรม Adobe Flash CS3




Button                                                                      Symbol        :
                                                                            เปนSymbol
                                                                            ที่ใชสาหรับเปนปุมเทานั้น




                                                                      ่
                          Graphic Symbol : เหมาะสาหรับการทางานกับภาพนิง




ฝกทักษะการวาดโดยใชเครื่องมือของFlash
         1. วาดวงกลมโดยเลือกเครื่องมือ Oval Tool
ใชวิธีการคลิกเมาสคางไว ลากเมาสเพื่อสาดใหไดตามขนาดที่ตองการ
แลวก็ปลอย
หากตองการวงกลมที่กลมสนิทใหกดปุม Shift คางเอาไวดวย
ในขณะที่ทาการลากเมาส




         2.



วาดสีเ่ หลี่ยมโดยเลือกเครื่องมือRectangle Tool ใชวิธีการคลิกเมาสคางไว ลากเมาสเพื่อสาดให
ไดตามขนาดที่ตองการ แลวก็ปลอย
                                                                        คู่มืออบรม Adobe Flash CS3



วาดสีเ่ หลี่ยมจัตุรัสใหกดปุม Shift คางเอาไวดวยในขณะที่ทาการลากเมาส
                  ี
วาดสีเ่ หลี่ยมที่มมุมมลระหวางการวาดใหกดปุมลูกศรลง คางเอาไว สังเกตมุมของสี่เหลี่ยมจะโคง
มลขึ้น ถาตองการใหกลับเปนมุมฉากเหมือนเดิมก็กดปุมลูกศรขึน    ้




         3. วาดเสนดวยเครื่องมือ Line Tool       ใชสาหรับวาดเสนตรง
                                 สามารถดัดเสนใหโคงโดยใชเครื่องมือ Selection Tool
                                        ่    ี
ซึ่งจะทาใหการวาดนั้นสะดวกปละสวยงามยิงขึ้น วิธการวาดคือคลิกเมาสคางไว
ลากเมาสเพื่อวาดใหไดตามขนาดที่ตองการ แลวก็ปลอย การดัดเสน ใชเครื่องมือ Selection Tool
เมื่อนาเมาสเขาไปใกลบริเวณที่เปนจุดตัดของเสนเมาสจะมี ลักษณะเปนมุมฉากใตลูกศร แสดงวาดัดมุมได
หากตองการดัดเสนใหนาเมาสไปวางใกลเสนสังเกตวาจะมีลักษณะ เปนเสนโคงใตลูกศรแสดงวาดัดเสนใหโคงได
                                                                       คู่มืออบรม Adobe Flash CS3




การดาเนินการกับกราฟิกออฟเจ็ค

          ในโปรแกรม Flash ทุกสิ่งที่อยูบนสเตจจะถือวาเปนกราฟกออบเจ็คที่เราสามารถเคลื่อนยาย คัดลอก ลบ
วางซอน รวมถึงความสามารถในการลิ้งค สิ่งที่ตองคานึงถึงคือ
                                                  ่
การเปลี่ยนแปลงลายเสนและรูปทรงของออบเจ็คหนึงอาจ สงผลกระทบตอลายเสน
และรูปทรงของออบเจ็คอื่นที่อยูในเลเยอรเดียวกันได
                                                                              ่
          การเลือกออบเจ็ค กอนที่จะแกไขลักษณะของออบเจ็ค จะตองเลือกบริเวณทีตองการเปลี่ยนแปลงเสีย
กอน โดยเราสามารถทาได หลายวิธีเชนArrow Tool , Laso Toolหรือใชคาสั่งจากแปนคียบอรด
           ู
บริเวณที่ถกเลือกจะแสดงดวยลายจุด จากนั้น เราจึงทาการเปลี่ยนแปลงบริเวณนั้นไดตามตองการ
นอกจากนั้นเรายังสามารถรวมกลุมของออบเจ็คเขาดวยกัน เพื่อจะ ทาการแกไขออกเจ็คทั้งหมดพรอมๆ กัน
                                   ่
โปรแกรมจะแสดงกลุมออบเจ็คทีถูกเลือกดวยเสนกรอบสีเดียวกับ Highlight Color ที่ตั้งไวใน Preferences
                                          ู
          กรณีที่ไมตองการใหออบเจ็คที่ถกเลือกแสดงการไฮไลท ใหเลือกView > Hide
Edgesเพื่อซอนการแสดงลาย จุด หรือกรอบสีฟาที่จะปรากฏขึ้น
                       ้
และสั่งคาสั่งเดิมอีกครังหนึ่งเพื่อใหมีการแสดงไฮไลทเหมือนเดิม
เลือกออบเจ็คดวยArrow Tool
1. คลิกบริเวณของเสน สีพื้น ขอความ group หรืออินสแตนซที่ตองการเลือก ถาตองการเลือกบริเวณอื่น
เพิ่มเติมใหกดคียShiftขณะเลือกสวนของออบเจ็คตอไป




2.ดับเบิลคลิกที่เสน เพื่อเลือกเสนทั้งหมดที่เชื่อมตอกัน




                                   ้
3.ดับเบิลคลิกที่สีพื้น เพื่อเลือกทังเสนขอบ และสีพื้น
                                                                    คู่มืออบรม Adobe Flash CS3




                                              ้       ่
4. ลากเมาสลอมรอบบริเวณที่ตองการเลือก ออบเจ็คทังหมดทีอยูภายในบริเวณดังกลาวจะถูกเลือก ถา
กรอบที่ลากนั้นไมครอบคลุมทุกสวนของออบเจ็ค เสนขอบ และสีพื้นบางสวนของออบเจ็คก็จะถูกเลือก
ยกเวนออบเจ็ค ประเภทอินสแตนซ group หรือ type blocks ที่จะตองลอมรอบทุกสวนของออบเจ็คจึงจะเลือกได้




การแปลงรูปออบเจ็ค(Transforming Objects)
        เราสามารถแปลงรูปออบเจ็คที่อยูในรูปของกราฟก ขอความgroup หรืออินสแตนซไดดวยเครื่องมือFree
                                             ่
Transform Tool ที่อยูในทูลบ็อกซ หรือเลือกคาสังModify > Transform จากเมนูบาร จะปรากฎเสนกรอบ
                              ่                          ่
ขอบเขต และจุดควบคุมการเปลียนแปลง ที่มุมและดานทั้งสี่ ซึงจะใชเปนเครื่องมือในการแปลงรูปตอไปนี้
โดยอาจทา ไดทั้งการแปลงรูปอยางอิสระ หมุน ปด เอียง ยอ และขยาย
                                                                    คู่มืออบรม Adobe Flash CS3



วาดรูปดวยเครื่องมือ Flash8
       วาดใบไม :เพื่อฝกการใชเครื่องมือวาดเสน,ดัดเสน, และลงสี




1.เมื่อเปดไฟลเปลาๆขึ้นมาแลว ใหเลือกใชเครื่องมือ Line Tool      คลิกคางไวแลวลากเมาสดังรูป




2.แลวใชเครื่องมือ                                                              Selection Tool
เพื่อทาการดัดเสน มีวิธีคือ
เอาเมาสเขาไปวางใกลๆ เสน จะมีเสน
                                          ่
โคงใตลูกศร จากนั้นก็เลื่อนเมาสไปในทิศทางทีตองการดัดเสน
                                                                           คู่มืออบรม Adobe Flash CS3




3.จากนั้นก็เลือกเครื่องมือ Line Tool แลวทาการวาดอีกเสนหนึ่งดังภาพขางลางนี้ แลวใชเครื่องมือ
                                        ่
Selection Toolในการดัดเสนอีกครั้ง จะเริมปรากฎเปนรูปทรงของใบไมแลว

4.ใชเมาสจับเสนที่โผลออกมา(ใตเมาสจะมีเครื่องหมายมุมฉาก) ลากผากลางใบไมเพื่อเปนรายละเอียดของ ใบไม
แลวดัดเสนตรงกลางใหโคงเพื่อมีมิติและสวยงาม




5.จากนั้นก็วาดและดัดเสนใหเปนดังภาพขางลาง
                                                                            คู่มืออบรม Adobe Flash CS3




6.เสนที่โผลเปนสวนเกินออกมาใหใชเครื่องมือSelection Toolคลิกเพื่อเลือกแลวกดปุมDeleteที่คียบอรด
ไดเลยเพียงเทานี้ก็จะไดลายเสนที่เปนรูปใบไมเรียบรอย




7.เลือกสีที่ตองการจากชอ Fill ColorจากToolbox จากนั้นเลือกเครื่องมือPaint Bucket Tool เพื่อเท
สีลงไปยังรูปที่วาดเอาไว ก็จะไดใบไมอยางงาย ๆ
                                                                           คู่มืออบรม Adobe Flash CS3




วาดลูกบอลแกว:เพื่อฝกการใชเครื่องมือวาดวงกลม,เครื่องมือ Free Transform,การใช Layer,การใชสี,
และการสังเกตความสมจริงของวัตถุ




1.เมื่อเปดโปรแกรมขึ้นมาแลวเลือกเครื่องมือ Oval Tool การวาดใหไดวงกลมจริงๆทาไดโดยกดShiftที่
คียบอรดแลวจึงลากเมาสเพื่อวาดรูปวงกลบบนเสตจ




2.จากนั้นจะเลือกสีที่มีการไลเฉดสี โดยเปด Color Mixer Panelที่คาสั่ง Windows > Color mixer Panel
เมื่อเปดขึ้นมาแลวทาการเลือกรูปแบบการใหเฉดสี ในที่นี้จะเลือกแบบLinear
                                                                               คู่มืออบรม Adobe Flash CS3




3.เลือกสีแรก ดับเบิลคลิกตรงลูกศรชี้เพื่อเลือกสีที่ตองการ สีที่สองก็ดับเบิลคลิกแลวเลือกสีเชนกัน




4.เมื่อเลือกสีที่ตองการไดแลวใหกลับมาที่สเตจ แลวเลือกเครื่องมือPaint Bucket Tool แลวคลิก
บริเวณสีพื้นของวงกลมเพื่อใชเทสีลงไป จานั้นใชเครื่องมือSelection Toolคลิกที่เสนแลวลบออกโดยกดDeleleที่
คียบอรด
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
                                                                          คู่มืออบรม Adobe Flash CS3



WorkShop 1

1. สร้างเอกสารใหม่ขึ้นมาตามขนาดที่ต้องการ ดังรูป สร้างเป็นขนาด 300 x 100 pixel




                              ่
2. สร้างวงกลมขึ้นมา โดยใช้เครืองมือ Oval Tool ดังรูป




                            ิ่
3. สร้าง Tween ของวงกลม ให้วงจากซ้ายไปขวา แล้ววิ่งกลับมาที่เดิม ดังรูป
                                                           คู่มืออบรม Adobe Flash CS3




                 ้
4. สร้าง layer ขึนมาอีกหนึ่ง layer ชื่อว่า action ดังรูป
                                                                                  คู่มืออบรม Adobe Flash CS3




5. ใส่ action script ให้กับ layer ที่มีชื่อว่า action โดยการเลือกที่ keyframe แล้วกด F9 ดังรูป




6. insert keyframe ลงไปที่ frame สุดท้าย




7. ใส่ action script ให้กับ keyframe ดังรูป
                                                   คู่มืออบรม Adobe Flash CS3




8. สร้าง layer ใหม่ขึ้นมาชื่อว่า control




9. ไปที่เมนู window > common libraries > buttons




10. เลือกปุ่ม play แล้วใส่ลงไปใน stage ดังรูป
                                                                 คู่มืออบรม Adobe Flash CS3




                                      ่
11. เลือกปุ่ม stop แล้วใส่ลงไปต่อจากปุม play ใน stage ดังรูป




12. เลือกปุ่ม pause แล้วใส่ลงไปต่อจากปุ่ม stop ใน stage ดังรูป
                                                                   คู่มืออบรม Adobe Flash CS3




13. เลือกปุ่ม back แล้วใส่ลงไปต่อจากปุ่ม pause ใน stage ดังรูป




14. เลือกปุ่ม forward แล้วใส่ลงไปต่อจากปุ่ม back ใน stage ดังรูป
                                                                      คู่มืออบรม Adobe Flash CS3




15. จากนั้นให้ใส่ action script ให้กับ ปุ่มดังนี้

15.1 คลิกที่ปุ่ม play กด F9 แล้วใส่ action script ให้กับปุ่ม ดังรูป
                                                                       คู่มืออบรม Adobe Flash CS3



15.2 คลิกที่ปุ่ม stop กด F9 แล้วใส่ action script ให้กับปุ่ม ดังรูป




15.3 คลิกที่ปุ่ม pause กด F9 แล้วใส่ action script ให้กับปุ่ม ดังรูป
                                                                        คู่มืออบรม Adobe Flash CS3



15.4 คลิกที่ปุ่ม back กด F9 แล้วใส่ action script ให้กับปุ่ม ดังรูป




                                                             ่
15.5 คลิกที่ปุ่ม forward กด F9 แล้วใส่ action script ให้กับปุม ดังรูป
                                                                                คู่มืออบรม Adobe Flash CS3



WorkShop 2

1. import เสียงที่ต้องการ โดยไปที่เมนู file > import > import to stage หรือกด ctrl + R ดังรูป




2. เลือกเสียงที่ต้องการ แล้วคลิก ok ดังรูป




3. เสียงที่ import เข้ามา จะอยู่ที่ Library (เมนู Window > Library หรือ กด Ctrl+L)




4. insert keyframe ลงไปใน frame ที่ 2 ลากไฟล์เสียงจาก Library ลงไปใน stage และตั้งชื่อ layer ว่า
sound จะได้ดังรูป
                                                                          คู่มืออบรม Adobe Flash CS3




4.1 ด้านล่างตรง properties ให้เลือกตรง Sync เป็น Start ดังรูป




5. สร้าง layer ใหม่ ตั้งชื่อว่า action




6. คลิกที่ keyframe ใน layer action แล้วกด F9 เพื่อใส่ action script ดังรูป




7. สร้าง layer ใหม่ให้ชื่อว่า control
                                                                คู่มืออบรม Adobe Flash CS3




8. ไปที่เมนู window > common libraries > buttons




9. เลือกปุ่ม play แล้วใส่ลงไปใน stage ดังรูป




10. เลือกปุ่ม stop แล้วใส่ลงไปใน stage ต่อจากปุ่ม play ดังรูป
                                                               คู่มืออบรม Adobe Flash CS3




11. คลิกที่ปุ่ม play แล้วกด F9 เพื่อใส่ action script ดังรูป




12. คลิกที่ปุ่ม stop แล้วกด F9 เพื่อใส่ action script ดังรูป
คู่มืออบรม Adobe Flash CS3
คู่มืออบรม Adobe Flash CS3
                                                                       คู่มืออบรม Adobe Flash CS3




                                          เอกสารอ้างอิง

ศูนย์พัฒนาทรัพยากรการศึกษา (CARD) มหาวิทยาลัยมหาสารคาม. การวาดการ์ตน Flash Professional
                                                                                 ู
            ,2550.
สานักบริการคอมพิวเตอร์ สถาบันเทคโนโลยีพระจอมเกล้าเจ้าคุณทหารลาดกระบัง. ความรู้พื้นฐานสาหรับ
          งานคอมพิวเตอร์กราฟิก Basic of Computer Graphic ,2550.
บุญญาดา ช้อนขุดทด. Insight Flash CS3 เจาะลึก อ่านง่าย ทาตามได้จริง. โปรวิชั่น จากัด , 2550.
อภิชัย เรืองศิริปิยะกุล. 2D Animation และ Interactive ด้วย Flash 8. ซีเอ็ดยูเคชั่น จากัด , 2550.

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:209
posted:2/10/2012
language:Thai
pages:61