Docstoc

Solid Edge

Document Sample
Solid Edge Powered By Docstoc
					Engineering and Technical Drawing
Using Solid Edge V16
By Jerry Craig

Series V16

PUBLICATIONS

SDC

Schroff Development Corporation www.schroff.com
www.schroff-europe.com

Solid Edge V16

2D Drawing

2D Sketches Chapter 2

Using 2D Sketches

Copyrighted Material
2D Drawing
2D Sketches 2D Profiles Create Part Create Assembly Selecting

Reference Planes

Entity Objects

Dimensioning

Copyrighted Material
Lines Arcs Circles and Ellipses Smart Dimensions Standard Dimensions Starting Setting Reference Point Key-In Values Zoom Window Zoom Smaller Fit

Profile View

Rectangles

Sketch Point

Display Commands

IntelliSketch Settings

Copyrighted Material
Geometric Relations

Pan

Editing Sketches

Tutorial

Problems

Copyrighted Material
Accurate Layout Creating Drawings Adding Text and Dimensions

Selecting Entities & Deleteing

Fillets and Chamfers

Trimming and Extending

Construction Lines

Printing

25

2D Drawing

Solid Edge V16

2D Drawings may take two forms:

2D Sketches show the outlines and locations of multiple shapes or parts to be designed.

2D Profiles must be closed shapes with no entities inside or crossing the sketch. The sketch at the right may be used to create a part by selecting specific shapes then “cleaning up” the outline by trimming inner curves. The final shape must be a single series of connected lines and arcs.

Copyrighted Material
Profile must be a closed figure with no internal lines.

Concept Sketch. (Cannot be used to create a part in this form).

Copyrighted Material
Additional sketches were used to define the protrusion at the middle and the holes in the part after the initial shape was created.

Copyrighted Material Copyrighted Material
26

Resulting 3D object with depth added.

Solid Edge V16

2D Drawing

Assembly Sketches (Layouts)

These are used to define the critical geometry in a series of mating parts. Elements from the master sketch may be selected to create the individual parts. This assures that the parts are the correct size and are located in exactly the right place. Elements of the part sketches which are derived from the master sketch may be associated (linked) back to the master sketch. This means that any change in the master sketch will update all the associated parts.

Copyrighted Material Copyrighted Material Copyrighted Material Copyrighted Material
27

Portions of the sketch were used to create the base of the roller assembly.

Other portions of the same sketch will be used to create the opening for the wheel.

Modeling the wheel is done by selecting the large circle from the master sketch. The final assembly is shown with the parts modeled exactly as they fit.

As you can see, 2D sketches are the basis for much of the design and part creation process. These sketches can be very general at first then, exact sizes can be assigned later. All parts associated to the master sketches will re-size to the new dimensions.

2D Drawing

Solid Edge V16

Starting a 2D Sketch

In this chapter all drawings will start from the Part Environment. Most of the commands and construction techniques are the same in other environments. If Solid Edge is already running, pop down the File menu .... Pick New … Select the More tab Use Normeng.par (inch)

Copyrighted Material Copyrighted Material Copyrighted Material
Front 2D Sketch selected

For an introduction to 2D sketches, we will use the option to create a sketch. This option allows the designer to create an overall master outline showing major features of the part. When the actual part creation takes place, elements from the master sketch will be copied to the part outline sketch. Watch the Status Bar for instructions and prompts.

· Pick the Front reference plane.

Copyrighted Material
Top Right 28

Solid Edge V16

2D Drawing

2D Sketch with Grid. Selecting a reference plane for the 2D sketch creates a 2D drawing screen. Turning on the Grid displays the Grid Tool Bar and places a grid on the screen.. Grid Icon

Copyrighted Material
Grid Tool Bar Face View of Front X - Z plane

Copyrighted Material
Zero Origin Point

Edge View of Right Y - Z plane

Edge View of Top X - Y plane

Grid Settings Tool Bar

Copyrighted Material Copyrighted Material
Grid Off/On Reset Origin To Zero Move Origin 29

Grid Options

Snap To Grid

2D Drawing

Solid Edge V16

Grid Options Dialog Box Grid settings may be adjusted for the type of sketch to be created. Major lines might be 1 inch while minor lines might be: 8 lines/inch = 1/8 inch (.125) 10 lines/inch = .10 inch, etc.

Snap To Grid locks the drawing geometry to the grid. This creates accurate geometry quickly without keying in distances as long as the points can be set to the grid locations.

Copyrighted Material Copyrighted Material Copyrighted Material Copyrighted Material
30 New Origin

Show Readouts turns on the X - Y display showing the cursor distance from the current Origin. Show Alignments projects a dashed line when the cursor is in line with existing geometry. Grid as Points. The grid may be displayed as points if prefered. Cursor Position Display. X and Y pointer locations are displayed as points are set. The distance is from the Origin.

Resetting the Origin is often necessary during 2D drawing construction. Default Zero Origin

Solid Edge V16

2D Drawing 2D Sketch Window

2D Sketch Window

Selecting a reference plane places a special window on the drawing. The view is looking straight at the selected reference plane. In this example the top and right planes appear as an edge and the front plane is the drawing surface. The profile will be created on the Front plane. The Drawing Tools Menu activates:

Copyrighted Material
Edge view of Top plane

Edge view of Right plane

Drawing Tools Menu
Pick Tool Line

Copyrighted Material
Draw

The sketch will be created on the surface of the Front plane.

Free Form Arc Arc Circle Rectangle

Fillet/Chamfer Trim/Extend Offset*

Copy from Sketch*(Include)/ Construction Entity flyout Move* Smart Dimension

Copyrighted Material
Edit

Connect*

Horizontal/Vertical* Tangent* Equal*

Copyrighted Material
Constrain*
31

Other Dim

( Illustration from Solid Edge Online Help )

Explore the commands. Remember that each icon with a small arrow at the lower right corner has a Fly Out with additional commands. * Advanced concepts are discussed in the next chapter.

2D Drawing

Solid Edge V16

Line

Starting the line command displays the ribbon bar at the top of the screen. Click a start point and move the mouse. The length of the line and the angle will display. · You can type in a length and an angle in the dialog boxes. · While drawing a line you can switch to the arc command and back. Line to Arc

Copyrighted Material
Switch between line/arc Intent Zone

Clicking the arc button on the ribbon bar switches to the arc command.

Copyrighted Material Copyrighted Material
Line Point Free Sketch Freehand drawing converted to geometry

· An Intent Zone icon is displayed on the end of the line. Moving the mouse through the 4 sectors produces a different result for each sector. out menu. Click to place or input coordinates. Points are placed as Construction Elements.

Point - Available from the fly

Free Sketch. Use mouse to

draw outline. Solid Edge converts to geometry. (Usually needs a lot of editing).

converts to BSPLINE geometry. Click curve to edit inflection points. Freehand courve or Bspline input points.

Curve Menu. Draws or

Copyrighted Material
Convert to Bspline 32

Solid Edge V16

2D Drawing

Arc

From the fly out menu, 3 options are possible.

Copyrighted Material
Tangent 3 Points

Center, Start, End

Depending on the option chosen, (line or arc) exact sizes may be set using the ribbon bar.

Circle

Copyrighted Material

Note: In some constructions it is easier and more accurate to draw a full circle then trim to define an arc.

5 options are shown on the circle fly out.

The ribbon bar accepts either diameter or radius.

Tangent can be: · Tangent to one entity · Tangent to two entities including the reference planes. You can set the radius then move the circle tangent. Many options exist. Try different commands and ways of using the commands. Online Help gives excellent instructions for the use of each option.

Copyrighted Material

Center 3 Points Tangent Ellipse Ellipse Radius/ 3 Points Center Diameter 2 Points

Copyrighted Material
33

2D Drawing

Solid Edge V16

Rectangle

Three construction methods are available:

· Use dialog boxes. Input Width, Height and Angle. · Click two points for the width and one point for the height. · Draw a diagonal sketch line with the mouse.

Copyrighted Material Copyrighted Material
Sketch Diagonal Line Rectangle Constructed

Sketch Editing Tools
Select Tool

Used to select entities for editing. Hold down the CTRL Key to select multiple entities. To delete an entity, select it and press the Delete Key

Fillet/Chamfer

Fillet will round a corner or add an arc between two entities. Often, Fillet is the easiest way to create an arc when the start/end/center points are not well defined. Chamfer will bevel a corner. The bevel can be the same angle or distance on both sides or, the bevel may be a different distance or angle on each side. Note the expanded ribbon bar.

Copyrighted Material Copyrighted Material
B A 34

Small rounds, fillets and chamfers should usually be added to the solid model after the major shape has been created.

Solid Edge V16

2D Drawing

Trim/Extend/Break

Trim

Trim Extend Break Corner

Copyrighted Material
Trim line

Trim is used to remove segments of entities. The segments are defined by intersections on the sketch. Multiple segments may be trimmed by sketching a line through each entity.

Extend will cause entities to intersect. Extend will not work if one entity does not provide a stop for the entity being extended. · You can extend a line by selecting the line and keying in a new length in the dialog box.

Copyrighted Material Copyrighted Material Copyrighted Material
35 Construction lines were used to locate the center for the circle. The Construction toggle is on the flyout with the Include command.

Break will slice an entity into two parts.

Construction Lines

Any entity may be designated as a construction element. This means that it is used to define geometry but is not considered as a part of the outline shape.

2D Drawing

Solid Edge V16

Move/Rotate/Mirror/Scale/Stretch/Delete

Move Rotate Mirror

Move. · First click the Select Tool. · Pick the object to move. (Hold down the CTRL Key to select multiple objects or use a window to select the objects within the window.) · Click where the object is now. · Click to set new location.

Copyrighted Material
Scale Stretch Delete

Dimensioning

Smart Dimensions

Copyrighted Material Copyrighted Material Copyrighted Material
36

Use where one entity is to be dimensioned. · Line · Circle · Arc All the dimensions shown are Smart Dimensions. Standard Dimensions

Distance Angle Coor- Sym- Dimension Between dinate metric Axis To change the size of an entity on the drawing: · Select the dimension. · Type in a new size.

Solid Edge V16

2D Drawing

Fill places a pattern or solid in a closed area. Fill Ribbon Bar:

Copyrighted Material Copyrighted Material

Display Commands
As work progresses, the screen size may need to be changed. · Zoom Window - magnify · Zoom Out (shrink) · Fit (re-size to fit screen) · Pan (slide without changing size) All allow for quick magnification, or re-sizing of the drawing image.

Main Toolbar- Top of Screen Zoom Zoom Fit Window Smaller /Larger Pan

Copyrighted Material Copyrighted Material
37

A "Wheel Mouse" may be used for fast zooms by activating the wheel.

2D Drawing

Solid Edge V16

IntelliSketch

You may have noticed a number of symbols on the lines of the previous examples. These are geometric indicators which constrain the geometry. As you draw these symbols appear. The check box turns the momentary indicators on/off.

Copyrighted Material

QuickPick

Copyrighted Material Copyrighted Material
QuickPick is a tool used to sort out the correct item when several possibilities exist due to stacked geometry. Park the mouse for a few seconds and dots will appear. Right-click for the selection list.

Geometric Relationships

As you draw some of the Connect Concentric Tangent relationships are automatically set. Sketches must have the proper relationships between entities in order to create actual parts. Sketches must be properly constrained to create the Horizontal/Vertical Co-Linear Parallel Perpendicular intended objects. · Remove a relationship by deleting the marker. · Add a relationship by selecting from the Relationships menu. This menu is near the bottom of the Draw Toolbar.

Copyrighted Material
Equal Symmetric 38

Symmetric Axis

Solid Edge V16

2D Drawing

Tutorial - Accurate layout approach

Draw the sketch for: Shaft Support Bracket. Refer back to this drawing as you complete the tutorial.

Copyrighted Material

Shaft Support Bracket

Copyrighted Material
__ Start Solid Edge Part __ Select Sketch from the left menu. __ Select the Front plane for this drawing.

Copyrighted Material Copyrighted Material
39

__ Turn ON the Grid.

__ Set the Grid for: 1.00 inch major lines, 8 minor (0.125 inch) lines. Activate Grid Snap

2D Drawing

Solid Edge V16

__ Start the Line command.

__ Using the Grid Readout start the line at __ X= -2.000, Y= .500 __ To X= -2.000, Y= 0.000 __ To X=3.000, Y= 0.000 __ To X= 3.000, Y=.500

Copyrighted Material
X=-2.000 Y=.500 Zero on Grid

X=3.000 Y= .500

__ Right-click to stop the line.

Copyrighted Material
Start

Auto Re-size

Copyrighted Material Copyrighted Material
40

End

Grid - Resizing __ Click on the Grid border. __ Drag the border to a new size. A Grid Size dialog box appears. Key in X,Y sizes or click the Auto-Resize icon.

Solid Edge V16 __ Start the Circle command. __ Set the radius for .875

2D Drawing

__ Use Grid readouts to position the center at X=000, Y=3.000. Click to place the circle.

Copyrighted Material Copyrighted Material Copyrighted Material
Turn Off the Grid New Grid Origin

__ Draw a short horizontal line from the upper end of the leftmost .500 length vertical line as shown. Be sure the IntelliSketch icon indicates a connect and horizontal conditions. __ Reset the Grid Origin to the lower right (X=3.00, Y=0.000) as shown. __ Start a circle. Set the radius = .750. __ Place the center at X= -.6250 and Y= 1.250. Click to set the circle. __ Pick Tools ... IntelliSketch Set the dialog box as shown

Watch for the Allignment Icons "Point On" and "Tangent"

__ Draw the Vertical and Tangent lines as shown.

Copyrighted Material
41

2D Drawing

Solid Edge V16

__ Start the Fillet command. Set the radius to .500. Pick the two lines as shown to create the radius.

The Fillet command will extend or trim the lines to create the correct radius.

Copyrighted Material
Fillet

Save the drawing as Tutorial1

Copyrighted Material
Trim

__ Use the Trim command to remove the excess arcs from the construction.

__ Draw the 1.000 diameter circle. Start the circle command. Move your mouse over the top arc then toward the center of the arc. A special icon will show when the center is selected. Click and set the circle size to 1.000. __ Use SmartDimension and regular dimension commands to place the dimensions on the drawing as shown.

Copyrighted Material Copyrighted Material
42

Remember to move your mouse over a arc or circle before you try to place a dimension to the center.

__ Save the Drawing as Tutorial1

Solid Edge V16

2D Drawing

· The sketch is complete. It can be used to create a solid part by selecting geometry from the layout. · At this time we will create a preliminary 2D drawing. This is often done for design approval. · Copy the sketch and dimensions to the Clip Board. __ Pick Edit. __ Pick Select All (All the elements on the drawing should change color). __ Click Copy. This places the selected elements on the Clipboard. This is one way of re-using a sketch in different Solid Edge models. You can re-edit a sketch after you click finish. __Click the sketch. __Click Edit __ Click the sketch icon.

Copyrighted Material

Copyrighted Material
Note: Save the Part as Sketch1

Creating a Drawing
In the next steps we will: 1. Open a Solid Edge Draft document. 2. Set the correct sheet size and title block. 3. Paste the drawing from the Clipboard. __ On the File menu pick New __ Click the More tab. __ Select Normeng.Dft The default sheet size and background are too big. __ At the bottom of the screen Right-Click the word Sheet. __ Pick Sheet Setup. Set “A” background.

Copyrighted Material

Set Size for “A” wide: __ Click Background and set for “A” __ Zoom to full screen: On the Main Ribbon Bar click Fit View.

The size tab should show "A-Wide"

Copyrighted Material
43

2D Drawing

Solid Edge V16

__ Turn on the Draw Toolbar

Select View Toolbars Toolbars Place a checkmark in the Draw box. Note: This method of creating drawings is useful for quick 2D sketches. It may be used with WORD and other editors for report writing by pasting from the clipboard.

Copyrighted Material Copyrighted Material Copyrighted Material Copyrighted Material
44

Except for these exercises we will use other tools to create detail drawings. __ On the Edit pop-down click Paste. The sketch will appear but in the wrong place. Click the sketch and hold down the left mouse key. Drag the sketch to the middle of the title block.

If necessary, use the Move (Draw Toolbar) command to move the sketch to the middle of the title block. Window the sketch then drag the sketch as shown.

Move is on a fly-out with several other commands. You may have to look for it if another command is current.

Solid Edge V16 __ Use the Text Tool to place text in the Title Block as shown. Input your own school/company and name.

2D Drawing Note: Place the text approximately then use the Select Tool to drag it to the desired location. Text height is .125” SAVE the drawing. This will insert the designer's name and date. School lab computers may not show the correct information. Use TEXT to put your name and date on the page as assigned.

Copyrighted Material

Copyrighted Material

__ Save the drawing. __ Print the drawing. Printing/Plotting will vary depending on the output devices available. Check with your instructor.

Copyrighted Material Copyrighted Material
45

__ Click Properties for more settings. You may have to turn the drawing to a horizontal direction (Landscape).

2D Drawing

Solid Edge V16

Exercise 1.

__ Layout the sketch in the Part Environment. __ Dimension the sketch.

__ Set up an “A” size sheet in the Draft Environment. __ Use the Clipboard to copy the sketch onto the A-size title block. __Move the sketch to the center of the sheet.

Copyrighted Material Copyrighted Material Copyrighted Material Copyrighted Material
46

You may need to turn on the Draw Toolbar in order to move the sketch to the middle of the title block. __Fill in the Title Block as shown. Use your name in the DR BY: box. __Save and print the drawing. Drawing Name: Baffle Plate

Solid Edge V16

2D Drawing

Exercise 2.

Create the sketch for the part shown below.

Follow the steps as shown in Exercise 1. Create a drawing, dimension and print.

Copyrighted Material Copyrighted Material Copyrighted Material Copyrighted Material
47

2D Drawing Exercise 3. Layout the sketch as shown. Dimension as shown. Create a drawing.

Solid Edge V16

Copyrighted Material Copyrighted Material

Part Name: TEMPLATE

Exercise 4. Do the Tutorial.

Copyrighted Material Copyrighted Material
48


				
DOCUMENT INFO
Shared By:
Categories:
Tags: Tutorials
Stats:
views:899
posted:9/13/2009
language:English
pages:25