PSPICE

Document Sample
PSPICE Powered By Docstoc
					PSPICE - Review

 Kishore C. Acharya
Starting Simulation with PSPICE
• Launch PSPICE design Manager
• Create a New Work Space or Open an
  Existing one
• Launch Schematics
• Build Simulation Diagram by drawing on
  the schematic


                  Kishore Acharya          2
       Some PSPICE Commands
•   CTRL G – Get Components and place
•   CTRL W – To connect components
•   CTRL R – Rotate Components
•   CTRL F – Flip (Horizontally) Component
•   CTRL R – Rotate Components
•   CTRL L – Redraw
•   Hitting escape exits from command
•   Hitting space bar invokes last command
•   Pressing F11 Starts Simulation
                      Kishore Acharya        3
      Adding Custom Models
• From Analysis Menu select item Library
  and Include Files
• Click on Browse
  – Navigate and Select appropriate .txt file
• Click on Add Include Button
• Exit


                      Kishore Acharya           4
   Attaching Custom Model to a
              device
• The Schematic must be drawn using components from
  breakout library e.g. Mbreakp, Mbreakn, Qbreak etc. for
  PMOS, Nmos, BJT etc. respectively
• Save Schematic
• High Light the device to be attached with the custom
  model by clicking on it.
• From Edit menu select item Model
• From the Dialog Box click on Change Model Reference
  Button and type the name from the custom model text file
  e.g. CMOSN, CMOSP for Level 3 Model of T15D
                         Kishore Acharya                     5
 Verification that Custom Model
            is attached
• High Light the Device in Schematic
• From Edit Menu select item Model
• From the dialog box click on Edit Instance Model
  (text)
• The appropriate Model will be displayed.
• Exit by clicking Cancel Button
• Clicking Save creates a local copy of the instance
  model that can be edited without affecting other
  circuits
                      Kishore Acharya                  6
     Setup for Simulation – DC Analysis

•   From Analysis menu select setup
•   Check DC Analysis box
•   Click DC Analysis button
•   On DC Analysis dialog box
    – Type Source Name (same as in schematic, e.g. Vds)
    – Set start, final and end values
    – Click radio buttons Voltage Source and Linear
• Click Nested Sweep Button (for nested sweep)
  otherwise exit.
                         Kishore Acharya                  7
  Setup for Simulation – DC Analysis
               Continued
• On Nested Sweep dialog box
  – Type Second Source Name (same as in
    schematic, e.g. Vgs)
  – Set start, final and end values
  – Click radio buttons Voltage Source and Linear
  – Check Enable Nested Sweep
• Exit Nested Sweep Box
• Exit Main Sweep Box
                    Kishore Acharya                 8
      Setup for Simulation – Transient
                  Analysis
•   From Analysis menu select setup
•   Check Transient Analysis box
•   Click Transient Analysis button
•   On Transient Analysis dialog box
    – Set print step to 20ns
    – Set Final time to the appropriate value( usually
      4 to 5 times the period of input pulse)
• Exit Dialog Box
                       Kishore Acharya                   9
Pulse Specification for Transient

V2

V1
      td   tr    PW      tf
                        PER                     Example
     Select operating Frequency F hz.           F = 10 Mhz
     PER = 1/F, PW = 0.45 PER,                  PER = 1/107 = 100 ns
                                                PW = 0.45 PER = 45 ns
     tr=tf = 0.05 PER, td = 0
                                                tr = tf = 0.05 PER = 5 ns

                              Kishore Acharya                         10
Typical Input output waveform
      for digital circuits
Input Pulse      Output Waveform
                 Non Inverted




              Kishore Acharya      11
 Typical Input output waveform for
digital circuits at the maximum limit

  Input Pulse             Output Waveform
                          Non Inverted




 At the maximum operating frequency output pulse is not
 square any more and it barely touches the input pulse.


                       Kishore Acharya                    12
          Viewing Waveform
• Waveform will be displayed automatically
  if a Voltage Marker from Marker Menu is
  placed on the desired output
• Otherwise go to menu item Trace and select
  Add Trace
  – Add trace dialog box will list all available
    output
  – Click on the desired output
                      Kishore Acharya              13
         Copying Schematic
• To copy schematic into another application
  – Draw a box around the diagram by dragging the
    mouse (selected items will turn red)
  – From Edit Menu Select Copy to Clipboard
    option




                    Kishore Acharya             14
        Copying a Waveform
• From Edit Menu use Select all command
• From Edit menu use Copy command
  – Note: Only plot data values are copied not the
    graph
• Paste copied data values it into a Microsoft
  excel
  – Draw Scatter graph with the data

                     Kishore Acharya                 15

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:51
posted:12/19/2011
language:English
pages:15