Docstoc

ArcView Manual

Document Sample
ArcView Manual Powered By Docstoc
					Introduction to ArcView (3.x)


            Part 1




              1
Introduction to ArcView 3.x ..........................................................................................................................3
The Interface ..................................................................................................................................................3
Views .............................................................................................................................................................4
     Adding a theme .....................................................................................................................................4
     Displaying the attribute data .................................................................................................................4
     Zooming in and out and View Extent ...................................................................................................5
     Switching themes on or off and hiding the legend ................................................................................5
     Moving themes around ..........................................................................................................................5
     Labelling features ..................................................................................................................................5
     Viewing the attribute table ....................................................................................................................6
     Extracting subsets..................................................................................................................................6
     Projections .............................................................................................................................................6
     Images....................................................................................................................................................7
Tables .............................................................................................................................................................7
     Adding fields and editing tables ............................................................................................................7
     Bringing in point data (.dbf or text files) ..............................................................................................7
     GPS Extensions & Software .................................................................................................................8
     Spatial joins ...........................................................................................................................................8
     Joining attribute tables ..........................................................................................................................8
     Summarising data ..................................................................................................................................9
Layouts ...........................................................................................................................................................9
     Making a layout using a template..........................................................................................................9
     Making a layout without using a template ..........................................................................................10
     Maptools Extension .............................................................................................................................10
     Page Setup and Properties ...................................................................................................................10
Creating shapes and editing .........................................................................................................................10
     Extensions ...........................................................................................................................................10
Further Notes ...............................................................................................................................................11
     Export options .....................................................................................................................................11
     Metadata ..............................................................................................................................................11
     Symbol palettes ...................................................................................................................................11
     Mapping themes in a View .................................................................................................................12
     Exercise 1: ...........................................................................................................................................12
     Exercise 2: ...........................................................................................................................................12
     Exercise 3: ...........................................................................................................................................12
     Mapping point data at exact (GPS) locations in a View ...................................................................13
     Exercise 4: ...........................................................................................................................................13
     Exercise 5: ...........................................................................................................................................13
     Exercise 6: ...........................................................................................................................................13
     Exercise 7: ...........................................................................................................................................13
     Layouts ................................................................................................................................................14
     Exercise 8: ...........................................................................................................................................14
     Exercise 9: ...........................................................................................................................................14
     Editing etc. ..........................................................................................................................................14
     Exercise 10: .........................................................................................................................................14
     Exercise 11: .........................................................................................................................................14
     Exercise 12: .........................................................................................................................................14
     Exercise 13: .........................................................................................................................................14
     Exercise 14: .........................................................................................................................................14




                                                                               2
Introduction to ArcView 3.x

ArcView is a GIS software package produced by ESRI (Environmental Systems Research Institute). It is an
easy to use, yet powerful mapping programme. It uses an object orientated programming language called
Avenue which allows essentially unlimited flexibility as new tools can be added to the base software as
Extensions. When ArcView entered the market it provided PC users with a fairly basic yet accessible GIS
package, in contrast to ARC/INFO which is a very powerful GIS largely suited to mainframe computers.
With the development of many useful extensions over recent years, several functions previously only
available with ARC/INFO are now available to the ArcView user. ReGIS and IDRISI are examples of
competing GIS software packages.


The Interface

On opening ArcView the Project window appears. Similarly to word-processing where letters and other
files are saved as documents, in ArcView maps created are saved as projects. The project window contains 5
other windows:
      Views
      Tables
      Charts
      Layouts
      Scripts

   A View is used to bring in different map layers (e.g. rivers, roads, towns) which are referred to as
    Themes. It is in the view that themes are edited, manipulated or created and where, for example colours
    and line thicknesses are defined. A shapefile theme is made up of 3 separate files with extensions .dbf,
    .shx and .shp. All 3 files must exist for ArcView to be able to read a theme. The .dbf file contains the
    data associated with the theme (see 2 below) while the .shx and .shp files contain the spatial information
    used by Arcview to enable it to draw the theme.
    Themes can be of at least 3 types: Shapefiles, Images, Grids.
    Shapefiles are vector themes i.e. the map layers are made up of a series of points (vertices) connected by
    lines. Images and grids are raster themes i.e. map layers are made up from pixels each having an
    associated ID and value. All themes have associated information which describe the features they depict.
    For example a map of vegetation will have details of each of the vegetation types defined.
   This information is held in a Table which is an integral part of the theme. Data stored in the table are
    referred to as attribute data.
   Just as data can be displayed as maps, they can also be graphed. The Chart window allows you to graph
    data stored in the attribute table.
   Views, tables and charts are used to define which information is mapped and how it should be
    displayed. A Layout is used to present all the themes brought into the view and/or tables and charts
    produced, as a composite formatted map for printing or exporting. It is here that the size of the map is
    determined, legends are applied and details such as a scale bar and north arrow are added.
   For those with programming expertise and the need to customise the interface or add tools to ArcView,
    Scripts can be created. A script simply refers to the code written to instruct ArcView to perform a
    particular task.

NB. When a map has been produced, you may save your work as an ArcView Project. This produces a file
which has the extension .apr. The project (.apr) file only contains information on which themes you have
mapped, the legend classes you have used, the format of your layout etc. It does not include the themes
themselves, just links to them. Therefore, to copy a project (as a backup or to use on another computer) the
.apr file plus the 3 files (.dbf, .shx, .shp) for each theme used must also be copied as well as any legend files
(.avl) that may have been created.




                                                        3
Views

Views are used to edit, manipulate or create Themes. There are 3 types of Themes:

       Polygons
       Lines
       Points

Shapes, whether they are grids or boundaries, are referred to in Arcview as polygons. Features such as roads
or rivers are lines and features such as towns or boreholes are points. Polygon themes therefore have
perimeter and area attributes while line themes have length attributes. Points are created from x, y
co-ordinates.


Adding a theme
       Open the View window by double clicking on the view icon.
       Select View from the menu and Add Theme.
       Navigate to the theme required, select it and click OK.
       The theme legend is now displayed as a grey rectangular box with the theme name. When several
        themes have been added, the currently active theme is that which appears raised above the others.
        To make another theme the active theme, simply click on that theme‟s name.
       To rename a theme from e.g. settl96.shp to Settlements, select Theme from the menu, and then
        properties. Type in the new name in Theme name.

Displaying the attribute data
       To show the theme on the screen, tick the little grey box to the left of the theme name.
       Double click on the theme name to activate the Legend Editor.

        Polygon or line themes:
               Select from Legend Type either Graduated Colour (if the values you want to map are
               numbers) or Unique Value (if the values are text)

        Point themes:
                Select from Legend Type either Graduated Colour, Graduated Symbol or Unique Value

       If Graduated Colour or Graduated Symbol is selected, use Classify to define the type and number of
        class intervals you would like.
       Select from the Classification Field the field (column) in the attribute table which contains the data
        you want to map.
       To change the colour and shading, double click on the symbol next to the appropriate value. This
        will activate the Symbol Window. Change the way the symbol or polygon is displayed and click
        Apply to activate the changes. To change several consecutive symbols at once, select the first, hold
        down the shift key and click on the last one. To change several non-consecutive symbols at once,
        hold down the control key and select the symbols required. Note: the Symbol Window can also be
        obtained using the Window menu item.
       Close the Legend Editor by clicking on the cross in the top right corner.




                                                      4
Zooming in and out and View Extent
It is often necessary to zoom in or out when working with themes. The Layout reflects what is shown in the
View. It is therefore important to zoom in, in the View, to the area you are interested in. It is also useful if
you want to edit features of a theme. The following tools are available for zooming in and out and panning
across a map:

       Magnifying glass (with plus symbol) - Click on the top or bottom corner of the area in the view
        you would like to zoom in to and hold down the mouse button. Drag the mouse to draw a rectangle
        which contains the area you are interested in and release the mouse button. ArcView will then zoom
        in to the area defined.

       Magnifying glass (with minus symbol) - This tool works similarly to zoom in.

       Icon with arrows radiating inwards - Clicking on this will allow you to zoom in a set
        magnification at a time. Note that Zoom in under the View menu item does the same operation.

       Icon with arrows radiating outwards - Clicking on this will allow you to zoom out a set
        magnification at a time. Zoom out under the View menu item does the same operation.

       Full Extent - Found under the View menu item, this option draws all your themes at the same extent
        as the largest theme in the View.

       Zoom to theme - Found under the View menu item, this option draws all your themes at the same
        extent as the active theme in the View.

       Zoom previous - Zooms to the extent shown immediately previously.

       Hand icon - Pans across the map. Hold the mouse down and drag the hand symbol to move the map
        across the screen.


Switching themes on or off and hiding the legend
A theme can be displayed or turned off by clicking in the little grey box to the left of the theme name. Note
that the theme is still present when turned off – it is merely not displayed. Sometimes you might want to
display a theme using many class intervals which results in a large legend. This may make switching to other
themes cumbersome. To avoid this, the legend can also be turned off using Hide/show legend under the
View menu item.

Moving themes around
ArcView draws themes as layers in a View. Those which appear at the top of the View window are drawn
on top of those underneath and one theme may obscure another. It is therefore important to arrange the
themes in the correct order/sequence required. For example, a roads theme should appear on top of the
shadings of an elevation theme to avoid being obscured. To move a theme into the correct position, click on
the theme name to make it active, hold down the mouse button and drag the theme to the required place
above or below other themes in the View.

Labelling features
Polygon, line or point themes can be automatically labelled in the View using the themes attribute data. To
do this, use Auto-label under the Theme menu item. Select the Field (column) in your table containing the
data you would like to show as labels and choose from the options provided in the auto-label box. Labels
can then be individually edited, deleted or moved as required in the View. It is often better to set the font
you require in the Symbol Window before using Auto-label. Tick the Allow Overlapping Labels box and
keep the Remove Duplicates and Scale Labels boxes clear. Labelling is best done once the view is more or
less final.
                                                       5
Viewing the attribute table
To see the attribute table for a theme, choose Table under the Theme menu item. Each row of data
represents the data attached to a unique polygon, line segment or point, depending on the theme. Select a
row by clicking with the pointer. This makes the row (and feature) yellow. To select several consecutive
rows, select the first row then hold down the shift key and click on the last one. To select several non-
consecutive rows at once, hold down the control key and select the rows required. To view your selection,
go back to the view window by selecting your view under the Window menu item. In View, the selected
feature(s) will appear yellow.


Extracting subsets
Often it may be desirable to extract subsets from a theme. For example, perhaps you would like to see the
areas of land which are greater than 900 m in elevation or to select only those boreholes within a specific tds
range. To extract subsets use Query under the Theme menu item. Select the field which has the appropriate
information and make an equation (by double clicking on each item) e.g. altitude >= 900; tds < 2000. Then
click on New Set and only those data that meet the criteria are selected. Calculations can then be made on
this subset as described in the section on Tables (page 7). If it is desirable to keep this subset as a separate
shapefile, use Convert to Shapefile under the Theme menu to produce a new shapefile (theme) which only
contains the selected data.

Projections
Presenting a spherical surface (the earth) on a flat piece of paper requires that the area concerned is distorted
in some way. Factors which are affected include shape, angles and area and it is not possible to retain the
integrity of all three at once. It is possible to retain shape and angles but not area and, conversely, it is
possible to retain true area but not shape. When using a map to represent distances or areas accurately, it is
important to convert the map (shapefiles) to a projection appropriate to the required purposes. The
shapefiles provided for use with visualising conservancy data are all in what is termed Geographic
projection. This, in actual fact, means that the shapefiles are not projected. The shapefiles in this case are
spatially referenced using latitude and longitude. However, if you presented a map of Namibia using the
shapefile in Geographic projection, the scale bar would not reflect true distances. The convergence of lines
of longitude towards the poles, for example, would not be taken into account and east-west distances would
be too large. To use the map for calculating areas, it is first necessary convert it to a suitable projection such
as Albers equal area projection.

To do this, select Properties under the View menu item. Change Map Units to decimal degrees and Distance
Units to kilometres. Click on Projection and then choose Custom. Select the following:
        Projection = Albers equal area conic
        Spheroid = Bessel

If you are working with a shapefile of Namibia the following parameters can be used:
         Central meridian = 18.5
         Reference latitude = -23
         Standard parallel1 = -27
         Standard parallel2 = -19
         False easting= 0
         False northing= 0

        The most common projections you are likely to work with are Albers equal area, TM (Transverse
        Mercator) and UTM (Universal Transverse Mercator).

NB. To return to the Project window use the Window menu item. If you have already saved your project, the
name of the project will be listed and this refers to the project window. If you haven’t then the project window
is called ‘untitled’. Views (and tables and layouts) will be listed as view1, view2 etc. until you rename them (in
the project window). After renaming them, their new names will be listed. You can move between windows by
selecting from those windows listed in the Window menu item. Note that only those windows that are open
will be listed. To access a window which is not open, first go to the project window.

                                                        6
Images
You can display images in the view in the same way as with shapefiles. However, it is first important to set
the projection parameters for the image so that shapefiles displayed on top of the image will be correctly
spatially referenced. To add an image click „add theme‟ and select „Image data source‟ under data source
types. Then navigate to the image you would like to add and click. Several types of compression software
exist which greatly reduce the image size and make them quicker to use. Arcview comes with a MrSID
extension which allows you to add MrSID compressed images to your view. To activate an extension, go to
the Project window and select Extensions from the File menu item. Click in the box opposite the extension
you require and click OK.


 Exercise 1, 2, 3 *

[Note all required files for exercises are located in “C:\ConInfo\Documentation\Manuals\Arcview”


Tables

Many shapefiles are created with associated attribute data and these data can be immediately displayed as
shown in the previous section. However, it is frequently necessary to add external data to your polygon or
line themes or to create point themes from GPS data.

Data in spreadsheets or databases can be easily mapped in Arcview. Spreadsheet-type data such as .txt files
or .dbf files can be added to ArcView using the Add Table option under the Project menu in the Project
window. This process essentially copies the file into Arcview and there is no link back to the original file.
With compatible database software such as Microsoft Access, it is straightforward to access a database from
ArcView and link to data from tables or queries. This establishes a „live‟ link so that when data are edited or
added in Access the changes are automatically reflected in the table in Arcview. Databases can be accessed
from ArcView using the SQL connect option under the Project menu in the Project window. Data which
can be mapped include point data (e.g. GPS points) or data attributed to polygons (e.g. grids) or lines (e.g.
roads).


Adding fields and editing tables
To add new fields to an attribute table, go to the Table window and select Start Editing under the Table
menu item. Now select Add Field under the Edit menu item. Fill in the name for the field, the type (e.g.
number, text = string), width and number of decimal places. Click OK. You can now add data to the field by
first clicking on the edit button (next to the „i‟ button) and then clicking in the appropriate cell in the table
and typing in a value or text. Note: if the values in the field relate to values in another field you can use the
Calculate button to assign a value. When you have finished, select Stop Editing under the Table menu item
and save your changes.

To edit an attribute table, go to the Table window and select Start Editing under the Table menu item. Add
or edit data by first clicking on the edit button (next to the „i‟ button) and then clicking in the appropriate
cell in the table and typing in a value or text. When you have finished, select Stop Editing under the Table
menu item and save your changes. Note: data in linked database tables cannot be edited in Arcview.


Bringing in point data (.dbf or text files)
Create a text file or Excel file comprising at least 3 fields (columns) which contain the point data you would
like to map:

       Name/ID
       Latitude

                                                        7
         Longitude

Any number of further fields can be added containing additional data as required. Save this file as a .txt or
.dbf file. Now go to the Project window in ArcView and under the Project menu item select Add Table.
Find the file you have saved and click OK. Now go to the View menu item in the View window and select
Add Event Theme. Select the table you have just added and make sure that X = Longitude and Y = Latitude.
Click OK. A new theme containing your points should now be present in the View.

Note: Latitude and Longitude values should be in decimal degrees. In addition, Latitude values within
Namibia should always be negative. This is due to the quadrant of the world in which Namibia lies:


                                             Greenwich Meridian (0 degrees)

                                                                              Y (Latitude) = +ve
 Y (Latitude) = +ve                                                           X (Longitude) = +ve
 X (Longitude) = -ve




                                                                                                       Equator




        Y (Latitude) = -ve                                                       Y (Latitude) = -ve
        X (Longitude) = -ve                                                      X (Longitude) = +ve




GPS Extensions & Software
DNRGarmin - this software allows GPS data to be used in real time with Arcview so that you can follow
your postion on a map as you move. It also enables you to save GPS data as shapefiles and to upload data to
the GPS from Arcview. Similarly, Oziexplorer is compatible with almost any GPS and also provides a real
time tracking option and the ability to save data as Arcview shapefiles. Waypoint+ is much simpler software
allowing easy downloading of GPS data to be saved as text files and to other formats.

Spatial joins
If you have data which you would like to attribute to particular areas (e.g. quarter degree squares), you can
perform a spatial join. Say for example you have brought in a file with borehole coordinates and you would
like to assign each borehole to the correct quarter degree square. You can do this manually by joining the
tables of each theme using the „shape‟ attribute fields, or by using the geoprocessing extension.


Joining attribute tables
Use data from a common field to join attribute data to a shapefile. First, click on the name of the common
field in the table you wish to add – this is the column which you want to use to join the data. Now click on
the column which contains the same data in the shapefile’s attribute table – this is the column to which

                                                        8
you want to add the imported data. Click the join icon to join the first table to the shapefile attribute table.
You will see that the imported data are added to the end of the shapefile‟s attribute table in new columns.

Now go to the View Window and display the new data.


Summarising data
If the data are part of a higher classification e.g. boreholes in a particular rock type or quarter degree square,
they can be summarised according to these categories. So, for example, if one of your data fields assigns
each record to a rock type (perhaps after first having performed a spatial join, above), you could calculate
the average depth of boreholes in each rock type. To do this you would go to the table window and highlight
the field you wish to summarise your data by (e.g. rock type). Then go to „Field‟ and click on „summarise‟.
Then enter the path to save the results to, select the field you would like to summarise (e.g. borehole depth)
and then select „summarise by average‟. Now click on the „add‟ button and then click OK. You would then
have a table which lists for each rock type, the average borehole depth.


* Exercise 4, 5, 6, 7 *




Layouts
A layout in ArcView is where you format your map as it will be printed, add additional text, format legends,
add scale bars and north arrows etc. It is linked to the View, so all changes made in the View will be
automatically reflected in the Layout (unless you use the Simplify option – see below).

Making a layout using a template
The quickest and easiest way to make a layout from the View window is to click on Layout under the View
menu item. You will be prompted to select a layout format from a selection of templates (landscape or
portrait) and then a Layout will be opened. Remember that the Layout shows the same map extent as the
View window, so if you have zoomed into one section in your View, only this section will be displayed in
the Layout.

Unless you have used a custom-designed layout template, the layout will show a title, legend, scale and
north arrow. All of these can be moved by selecting and dragging, and the font, size, colour, shading etc can
be changed using the Symbol Window as described in „Displaying the attribute data‟, page 4. Additionally,
the properties of each item can be edited by double-clicking on it:

     Title – double click on the Title to display the Text Properties box where you can edit the text, set
    the alignment and vertical spacing and rotation angle.
     North arrow - double click on the arrow to open the North Arrow Manager box where you can
    choose the style of arrow you want.
     Scale - note that it is only correct to show a scale bar if the View has been projected.. Double click
    the scale bar to open the Scale Bar Properties box. Here you can set the style, units, interval (distance
    represented by one division), intervals (number of divisions) and left division (number of divisions to
    the left of 0).
     Legend - double click the legend to open the legend frame properties box. Here you can set the
    View from which the legend should come, however you are unlikely to need to change this. If the
    legend for a theme has been turned off in the View window using the Hide/Show Legend under the
    Theme menu item the legend for that theme will not appear in the Layout.

To only show selected themes in the Layout legend, use the Hide/Show Legend option in the View to hide
those you do not wish to show. The legend will display the theme names used in the view. Change the name

                                                        9
of the themes if required, as described in „Adding a theme‟, page 4. For example, a shapefile called
rainfall.shp could be renamed „Annual rainfall (mm)‟ so that this will appear in the legend.
If you wish to change the appearance of the legend further by, for example, splitting it into two columns or
changing symbols, it is necessary to use the Simplify option under the Graphics menu item. This allows
every piece of the legend to be edited as a separate item. Note, however, that when you use the Simplify
option, the legend is „unlinked‟ from the View and any subsequent changes to the View are not reflected
automatically in the Layout. Simplify should therefore only be used when you are sure you will not be
making any further changes to the view.

If edits to the Layout do not show on the screen, click and hold the right-hand mouse button to show a
submenu with the Refresh option. This redraws the Layout with all changes.


Making a layout without using a template
You can also make a Layout without using a template. From the Project window, select Layout and then
click New. This will open a blank layout to which you can add items individually:

        View frame – select the view frame button and click and drag to define the location on the page
         and size (scale) at which you would like to present your themes in the layout.
        Legend frame - select the legend frame button and click and drag to define the location on the
         page and size of legend you would like to present in the layout.
        Scale bar and North arrow – select the appropriate button and click and drag to define the
         location on the page and size you would like to present in the layout. Choose from the options
         provided.
        Adding text – select the T button and click in the layout where you would like the text to appear.
         Edit the text by first clicking on the arrow button and then double clicking on the text. The Symbol
         Window will appear and you can choose required fonts and styles.

Maptools Extension
This extension allows you to add a latitude/longitude grid around your map. Activate this extension in the
same way as described for the Xtools extension in „Extensions‟, page 10. Make sure that your View is
projected and then, in Layout, select the view frame by clicking on the map displayed. Now click on the blue
button with grid lines and choose the required option (usually latitude/longitude labels are all that are
required). Select the required latitude/longitude interval and click OK. This will place a labelled grid around
your map. Note: the proximity of the grid to your map is determined by the extent and shape of your view
frame. It often requires a certain amount of trial and error to get the optimal view frame for assigning a
latitude/longitude grid.

Page Setup and Properties
Alter page size, margins and other page settings using the Page Setup option under the Layout menu item in
the Layout window.


* Exercise 8, 9 *




Creating shapes and editing

Extensions
As mentioned in the Introduction, additional tools can be added to ArcView as extensions. Three very useful
extensions for manipulating shapefiles are Geoprocessing (which comes with Arcview), Xtools and Edit

                                                      10
Tools. These allow you to clip out themes from one theme using another as a template, to make one theme
from two themes (union), to convert a polygon theme to a line theme and vice versa, as well as several other
useful functions. To activate an extension, go to the Project window and select Extensions from the File
menu item. Click in the box opposite the extension you require and click OK. Now return to the View
window to make use of the additional menu item which now appears.


* Exercise 10, 11, 12, 13, 14 *



Further Notes

Export options
Layouts or Views can be exported as bitmap or windows metafiles or jpegs using Export under the File
menu item. If you have Acrobat distiller it is also possible to save your layout as a .pdf file.

Metadata
When producing a new shapefile (for example new roads or landmarks) it is very important to keep a record
of how the data were recorded and information on any projections used. If a GPS is used, a record should be
kept of which datum the GPS was set on. These details are very important when shapefiles change hands to
allow users to know what form the data are in, their level of accuracy and their limitations.

Symbol palettes
The default symbol palette provides a relatively limited set of formatting options. Many more palettes are
available in the folder esri/av_gis30/Arcview/symbols. To add a new palette icon in the Symbol Window,
click on „load‟ and navigate to the folder above. Choose the palette you like to add and click on it. The new
options will now be available in the Symbol Window.




                                                      11
Exercises
Mapping themes in a View

Exercise 1:
Produce a map showing Namibia with the boundary as a brown line, trunk and main roads as thin red lines
and main towns as labelled black triangles.

       Add 3 themes to the view – Namibia, roads and main_towns.
       Make the Namibia theme active and use the Symbol Window to make the shape clear with outline
        thickness 2 and colour brown, as described in „Displaying the attribute data‟, page 4
       Restrict the roads to display only trunk and main roads by selecting „type = main‟ and „type = trunk‟
        in the theme properties.
       In the same way, make the roads red with thickness 1 and depict the main towns as black triangles
        size 8. Use Auto-Label to label the towns as described in „Labelling features‟, page 5.
       Save the project as „Namibia.apr‟


Exercise 2:
Produce a map of Namibia showing the river catchments and main rivers. Make the country outline orange
and thickness 2 and turn off the fill colour. Add the catchments and shade them different colours but take off
the outline. Add pans and shade them yellow, also without an outline. Now add rivers but restrict the theme
to display only main rivers by setting the theme properties. Project the view using Albers equal area
projection. Label the rivers. Save the project as „Rivers_and_catchments‟.

       Add 4 themes to the view – Namibia, catchments, rivers and pans.
       Make the Namibia theme active and use the Symbol Window to make the shape clear with outline
        thickness 2 and colour orange, as described in „Displaying the attribute data‟, page 4
       Use unique value and the catchment field in the legend editor to shade the catchments different
        colours. Make the outline clear.
       In the same way add pans and make them yellow.
       Add the rivers and restrict the theme to main rivers by selecting „type = main‟ in the theme
        properties.
       Go to the view properties and enter the projection parameters for Albers equal area.
       Label the rivers
       Save the project as „Rivers_and_catchments.apr‟.


Exercise 3:
Produce a map which contains the image file called „Tsiseb.sid‟ with roads and settlements on top. Project
the view according to the following parameters: projection = UTM, zone =33, spheroid = Bessel. Remember
to set the false northing to 10000000. Display the roads by category in different thicknesses of red. Make the
settlement points circles and a light blue colour. Label the settlements with text colour = yellow. Save the
project as „Brandberg.apr‟

       Add 3 themes to the view – Tsiseb.sid, Roads, settlements and towns (remember to turn on the
        MrSid extension)
       Project the view, as described in „Projections‟, page 6
       Restrict the roads to display only those in Tsiseb by selecting „cons_name = Tsiseb in the theme
        properties. Depict the roads in red using legend type = each unique value and value field = category
        (Main, district and track). Make main roads size 2, district roads size 1 and tracks size 0.5 and
        dashed
       In the same way restrict the settlements theme to display only those in Tsiseb by selecting
        „cons_name = Tsiseb in the theme properties. Change the symbol colour to light blue.

                                                     12
       Change the text colour in the Symbol Window to yellow and label the settlements


Mapping point data at exact (GPS) locations in a View

Exercise 4:
Produce a map (in a View) showing the locations of boreholes. Project the view using Albers equal area.
Display TDS using 5 classes with a dot size of 4. Use the data in the dbf file called Borehole_data.dbf. Add
a string field to the attribute table called TDS_Cat. Use the query builder and calculator to add the following
categories to the new field: potable, livestock only, unusable. Now display the points using this new field
TDS_Cat.

       Add Namibia.shp to the view and take out the fill colour.
       Project the view as described in „Projections‟, page 6
       Now add the table Borehole_data.dbf using the „add table‟ option under „project‟ in the table
        window.
       In the view window, use „add event theme‟ (under the view menu option) to display the data
       Set the legend type to graduated colour and the classification field to TDS.
       Go to the table window, „start editing‟ and „add field‟. Name the field TDS_Cat and set the type to
        string and make the width 20.
       Select „query‟ from the table menu and select TDS <= 2000. Make sure the field name TDS_Cat is
        selected and click on the calculator button. In the white box, type “Potable”. Remember to use
        quotes as it is a string. Now repeat the process for TDS > 2000 and < = 5000. Make TDS_Cat =
        “Livestock only”. Repeat again for TDS > 5000 and make TDS_Cat = “Unusable”. Save edits
       Go back to the view and change the legend to display legend type = unique value and value field =
        TDS_Cat. Change the points to preferred colours and set the size to 4.

Exercise 5:
Perform a spatial join (either manually or using the geoprocessing extension) to assign the borehole data to
quarter degree squares.

       Add QDS_grid.shp to the view and take out the fill colour.
       Turn on the Geoprocessing extension.
       Select „assign data by location, click next. Now select assign data to borehole_data and assign data
        from QDS_grid.Click
       Go to the table attributes of borehole_data to check if quarter degree square has been added to the
        data

Exercise 6:
Now summarise the borehole data from exercise 4 to provide a table of average depth per quarter degree
square.
     Click on the field „square‟ in the attribute table.
     Go to „field‟ and „summarize‟ in the menu
     Set the path for the output and select the field „depth‟ and „summarize by‟ average.
     Click „add‟ and then ok

Exercise 7:
Join summarised data table to the attribute table of QDS_grid. Display average borehole depth by quarter
degree square using any legend classification type you like.
     With the new summarised table, click on the field „square‟. Now go to the attribute table of
        QDS_grid and click on the field called „square‟. The join icon becomes active. Click on this.
     Now go to the view window and display average borehole depth using the QDS shapefile. Set the
        legend type to graduated colour.
Save the project as Boreholes.apr

                                                      13
Layouts

Exercise 8:
Using the project saved in Exercise 1:(“Namibia.apr”), create a layout which includes all of the themes in
the view. Add a legend, scale bar, north arrow, title. Create a lat/long grid using the Maptools extension.
     In the view, change the names of the themes as desired using Theme properties in the Theme menu
        item.
     Open a layout and edit the title and legend on the map as described in „Making a layout using a
        template‟, page 9.
     Add a scale bar and north arrow (also described in „Making a layout using a template‟, page 9).
     Add a latitude/longitude grid as described in „Maptools Extension‟, page 10.

Exercise 9:
Use Exercise 7: as a starting point. Create another view which displays average yield per borehole by
quarter degree square. Display both views on one layout. Also display the picture „Otjikoto.gif‟ in a picture
frame somewhere in the layout. Add a legend and title for each map. Add a scale bar and north arrow. Also
add text providing projection details and put a border around the whole layout.
     Open the project called Boreholes.apr and make a new view, repeating exercise 6 & 7 but this time
        produce a map of Average yield per QDS
     Rename the new views to „Borehole Depth‟ and „Borehole Yield‟.
     In the view, change the names of the theme as desired using Theme properties in the Theme menu
        item.
     Create a Layout from scratch and insert 2 view frames, one for each view. Make sure the scale for
        each view frame is the same.
     Create a title as described in „Making a layout using a template‟, page 9.
     Add a separate legend for each of the views
     Add one scale and north arrow for the layout.
     Insert a picture frame containing the picture „Otjikoto.gif‟
     Add projection details in the same way as the Title was created.
     Add a border to the layout using the rectangle tool

Editing etc.

Exercise 10:
Creating shapefiles: Open a project and load the image 1920.sid. Remember to set the correct projection
parameters – use UTM zone 34. Create a polygon shapefile of the pans in the Nyae Nyae area. Create a
name field in the attribute table and add names of the pans according to the print out of the 1:250000 map
attached.

Exercise 11:
Clipping: (Geoprocessing wizard).Using the rivers shapefile, clip out only those rivers falling within
Khomas region.

Exercise 12:
Union: (Geoprocessing wizard).To create a shapefile of Namibia with pans included, union the Namibia
shapefile with the pans shapefile. Edit the attribute table to indicate pans (and the rest of the country).

Exercise 13:
Centres: (Xtools extension). Produce a point shapefile of the centres of the pans you drew in exercise 10

Exercise 14:
Buffer: (Xtools extension). Produce a polygon shapefile depicting a 10km buffer area around the main
towns of Namibia.


                                                      14

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:14
posted:12/4/2011
language:English
pages:14