Docstoc

TSR Technical Overview

Document Sample
TSR Technical Overview Powered By Docstoc
					Avici TSR – An overview

“True scalable routing”


          Ides Vanneuville
      Systems Engineer - EMEA




              Avici Company Confidential
  Architecture for the 21st Century Network
    Agenda
   Introduction
   Next (best) generation networking
   Software features
   Hardware features
   Summary




                       Best generation networking
     Who is Avici ?
   Founded: 1996 Billerica, MA
   Mission: To market scalable core routers that delivers service
    providers reduced capital and operational expenditures and simplified
    operations without service disruptions
   Public Company (Nasdaq AVCI), $ 240 million raised
   400 + employees worldwide, 11 in Europe
   Gained market share (in last 12 months)
                                                              16 M$

        2% in core router market (+1G links)                 14 M$
                                                              12 M$

        6.5% in core router market (10G links)               10 M$
                                                              8 M$
                                                              6 M$
                                                              4 M$
                                                              2 M$
                                                                M$
                                                                      Q1 00   Q2 00   Q3 00   Q4 00   Q1 01


                                 Best generation networking
Next generation network



     Avici                                       Avici




                      Optical Core



     Avici                                       Avici

                  Provider IP Core (P)

                    Provider Edge (PE)

             Customer Premise Equipment (CE)


                    Best generation networking
 Software features




            Avici Company Confidential
Architecture for the 21st Century Network
    About IPriori
   Unicast Routing
       Fully featured BGP-4 Implementation
               – Confederates, Route Reflectors, damping, policy, Route
                 Redistribution, Aggregation, dynamic configuration, peer security
       IGP Support
            IS-IS
               – Level 1 and 2 support, Route Redistribution, Database overflow
                 support, passive interface support
            OSPF
               – Stub Area support, Virtual links, Router Summarization, Passive
                 Interface support, Route Redistribution

   Multicast Routing
            PIM Sparse Intermediate Point
            PIM Dense/Sparse, Auto-RP, MSDP, MBGP for mcast NLRI



                                  Best generation networking
        Easy Migration - Industry CLI

server-id 2 upper                            router bgp 4293                                   ip route 5.5.5.0 255.255.255.0 null0
hostname bay_TWO_UPPER_server                 bgp router-id 1.1.1.1                            ip community-list 1 deny 45940756
system-password 7 S9bQQdb9Sd                  bgp dampening route-map 1                        ip community-list 1 deny 46071828
                                              redistribute connected route-map connected-bgp   ip community-list 1 deny 46006292
interface Loopback 0                          redistribute static route-map static-bgp
 ip address 6.6.6.1 255.255.255.0                                                              ip as-path access-list 1 permit ^$
                                              neighbor ebgp peer-group
                                                                                               ip as-path access-list 100 deny _1_
 no shutdown                                  neighbor ebgp send-community
                                              neighbor 3.1.1.2 remote-as 200                   ip as-path access-list 101 permit _65010_
interface Ethernet 0
                                              neighbor 3.1.1.2 peer-group ebgp                 ip as-path access-list 286 permit _286_
 ip address 10.5.222.1 255.255.0.0
                                              neighbor 3.1.1.2 timers 6                        ip as-path access-list 286 permit _3561_
 no shutdown                                  neighbor ibgp peer-group                         ip as-path access-list 286 permit _701_
module 1/15 4xoc3c                            neighbor ibgp remote-as 4293                     route-map EBGPMAP permit 10
 no shutdown                                  neighbor ibgp send-community                      set local-preference 25
interface pos 1/15/1                          neighbor ibgp route-map IBGPMAP out               set metric 150
 ip address 1.1.1.1 255.255.255.0             neighbor 1.1.1.2 remote-as 4293                  route-map IBGPMAP deny 10
                                              neighbor 1.1.1.2 next-hop-self
 crc 16                                                                                         match as-path 100 286
                                              neighbor 1.1.1.2 route-reflector-client
 no keepalive                                                                                  route-map IBGPMAP permit 20
                                              neighbor 1.1.1.2 timers 180
 sonet scramble-atm                           neighbor 2.1.1.2 remote-as 4293                   set community 45940837
                                              neighbor 2.1.1.2 next-hop-self                    set local-preference 80
 no shutdown
                                              neighbor 2.1.1.2 route-reflector-client           set metric 10
module 1/17 1xoc48c
                                              neighbor 2.1.1.2 send-community                  route-map connected-bgp permit 10
 no shutdown                                  neighbor 2.1.1.2 timers 180                       set community 45940847
interface pos 1/17/1                          neighbor 2.1.1.2 route-map IBGPMAP out            set origin igp
 clock source internal                        neighbor 10.10.10.2 remote-as 100                route-map static-bgp permit 10
 ip address 10.6.222.7.1 255.255.0.0          neighbor 10.10.10.2 timers 180                    set community 45940848
 no keepalive                                                                                   set origin igp
 sonet scramble-atm                                                                            bay 1/1
 no shutdown                                                                                   logging console platform all system bgp
router ospf 100                                                                                end
 network 10.10.10.0 0.0.0.255 area 0.0.0.0




                                                           Best generation networking
    Management and Security
   SNMP
             Standard and vendor-specific MIBS
             RMON Events and Alarms Group
             64bit counters
   System event log for all events
             Protocol activity (tracing)
             Local and remote SYSLOG
             Log all CLI commands
   Standby Route Servers
        Dual Servers can be deployed for additional redundancy
   Traffic separation
        All ForMe traffic is classified into 24 application-specific queues serviced by
         WRR to avoid starvation of control traffic and ensure against DoS attack
   Configurable for ForMe Traffic Filters
   Security
        TACACS+
        Secure Shell

                                      Best generation networking
    Network and Traffic Engineering
   Leverage emerging D-WDM Technology
   Get ahead of the serial bandwidth curve
   Stabilize topology
   Enable Rapid Provisioning
   Simplify the IP routing mesh
   Provide Protection options
   Provide TE network for the transport of Diff-serv traffic
   Enable Circuit Emulation/Private Line Service
   Enable 45ms restoration




                         Best generation networking
  Composite Links
                                                        Combines up to 64 physical
                                                         connections to a single logical
                                                         connection
          OC-48c
          OC-48c 10G                                    Removes serial bandwidth
          OC-48c vOC192
          OC-48c
                                                         limitations
                                                        Granular bandwidth scaling
                                                        4-1 speed mismatch
!
interface pos 2/29/1
                                                        Preserves packet sequence
  no ip address
  no keepalive                                          Add/remove trunks
  sonet scramble-atm
  no shutdown                                            dynamically
!
interface composite-link TSR1_CL                        Recovery in 45ms
  ip address 100.100.100.1 255.255.255.0
  peer default ip address 100.100.100.2
  member-link POS 1/22/1
                                                        Compartmentalizes link failure
  member-link POS 1/37/1
  member-link POS 1/39/1                                Routing table stability
  member-link POS 2/29/1
  no shutdown




                                       Best generation networking
  Composite Links & intelligent optics
                                               TSR monitors load on composite
                                                links
Composite Link                                        If total premium traffic exceeds a
    4
    3λ
                                                       limit, shifts ports from other links



                    Optical Switches



                                                  • TSR signals optical switch to
  Composite Link                                  reassign wavelength to high traffic
      4λ
      3                                           link
     Label Switch Router                                     • Dynamic reallocation of total
                                                             network
        Label Switch Router
                 Demonstrated interoperability
                                Best generation networking
SuperCOM 2001 demo




          Best generation networking
MPLS Traffic Engineering
   Ingress, Midpoint, and Egress
        Penultimate Hop Popping is NOT mandatory
   Ingress behavior allows unparalleled tunnel
    scaling
   Constraint Based Routing with Avici
    enhancements
   Enhanced RSVP signaling for Label Distribution
   Enhanced OSPF and IS-IS to support TE
   LDP
   End to end TE instrumentation for network mngt
   Tight Integration with Composite Links
   Hardware label switching on OC-3, OC-12, OC-
    48, OC-192 and Gigabit Ethernet

                        Best generation networking
           Traffic Engineering
                                                                            Router K's Next
                                                                            Hop For Routes in
                                                                            ISP 1                        Subscriber
                                                                  EGRESS
                                                                   LSR                           I         ISP 1
                                           Backbone                               BGP
               Shortest Path to            Provider                   K         Router E's Next Hop
             ISPs 1, 2, 3, and 4
                                                                                For Routes in ISP 2
                                   B                                                                     Subscriber
             INGRESS                                                              E      BGP      J        ISP 2
               LSR                                     C
Incoming Transit
    Traffic         A
                                                                                        Router G's Next Hop
                                                                                        For Routes in ISP 3
                                                                                G

                                       D                      F                EGRESS BGP                     Subscriber
                                                                            BGP LSR                  H
                                                                                                                ISP 3

                                                    Subscriber              M
                                                                                  Router G's Next Hop
                                                                                  For Routes in ISP 4
                                                      ISP 4

                                               Best generation networking
    Optimized Path Layout
   Intelligent MPLS Reflood Timing
       Improve responsiveness of Ingress path layout
   Resilience Optimization
       Recover from MPLS failures with minimal impact to core
        topology
   Adaptivity Optimization
       Take full advantage of positive changes in the core topology
       Rebuild LSPs, ordered by required bandwidth
                                                   5      0% loaded, 600sec

                                        200 sec
                                                                D
                                                                          4   50% loaded, 180sec
                                TE      100 sec                               C
                              Reflood
                              Timing                                                3       90% loaded, 20sec
                                         15 sec                                         B
                                                                                             2   95% loaded, 10sec
                                          5 sec                                                  A
                                                                                                     1   99% loaded, 3 sec
                                        T=0
                                                       Percentage of link loading
                             Best generation networking
Integration with Composite Trunks




                        Compose Trunk




                                                        Subnet 1
Subnet 1
                                                        Subnet 2
Subnet 2


      Higher Pre-emption value affects tunnel reroute
 Re-route time affected by reservable bandwidth attribute
                       Best generation networking
    MPLS Fast-Reroute Protection

                A            B                C                   D       E




                     I              H                         G       F



               Router switches traffic to pre-configured backup

   Allows identification of which traffic to protect
   Traffic switched to backup and traffic normally on link contend for resources
    using QoS – no traffic is discarded if link is not over-utilized
   Works for POS and gigabit Ethernet




                                 Best generation networking
     MPLS Fast-Reroute Drafts
   draft-atlas-rsvp-local-protect-interop-01.txt (Avici)
   draft-swallow-rsvp-bypass-label-01.txt (Cisco)
   draft-gan-fast-reroute-00.txt (Juniper)

Draft     Manageability                   Control               Scalability                   Interoperability
Interop   Local Protect Info (Available   Control Backup Paths Merging on Backups.            Creates Backups with
          and In-Use) & Label Info at     & LSPs via              Share Bandwidth with        any type of Ingress.
          Ingress. Make-Before-Break      Administrative-         Backups. Bypass Tunnels     As Ingress, supports
          on Backup Assures Protection    Colors, BW, Priorities, Possible for Many Tunnels   signalling required in
          Always Available.               & Hop-Limit                                         all drafts.

Bypass    Local Protect Info (Available   None                  Bypass Tunnels Used for Only interoperates
          and In-Use) & Label Info at                           Many Tunnels. Share     with itself (or Interop,
          Ingress. Make-Before-Break                            Bandwidth on Simple     depending on
          on Bypass Tunnels Only                                Backups. Backup Merging implementation)
                                                                Unspecified

Detour    None                            Control Backup Paths Merging on Backups. No         Only interoperates
                                          & LSPs via              Bandwidth Sharing. No       with itself (or Interop,
                                          Administrative-         Bypass Tunnels              depending on
                                          Colors, BW, Priorities,                             implementation)
                                          & Hop-Limit




                                                  Best generation networking
            VPN Support: RFC 2547
           VPN-P Support
                   Support for Multi-Protocol Extensions to BGP-4 to support
                    route-distinguisher
                   Compatible with Cisco, Juniper, Unisphere, Riverstone,
                    Alcatel, etc.
           Traffic Engineering/VPN tunnel integration
                   Provide a TE core for Virtual Private Networks
              Peering                                             Peering
               Node                                                Node




                           Avici   Optical   Optical   Avici
                           TSR     Switch    Switch    TSR

 Customer

                                                                              Customer
                     PE                                     PE
                    Node                                   Node




                           Avici   Optical   Optical   Avici
Customer                   TSR     Switch    Switch    TSR                  Customer



              Peering                                             Peering
               Node                                                Node

   Customer




                                                                  Best generation networking
    QoS Functional Summary
   Combination of WFQ, WRR, WRED and GPRA
    (CBR)
   Programmable ASIC Pipeline
   Multiple hierarchy of Algorithms
   Many iterations per algorithm implemented
   Minimum packet data handling
   Functionality increased for Multiservice module
   Counters maintained per interface,VC,class traffic
    management and accounting information




                        Best generation networking
   QoS Treatment per node




                                                        Direct Connect Fabric
                                                CTL
                                                REG
                                                PR
                                                BE




Group Policer   CIR, limit, non-conform actions (drop, flag)
Class Policer   CIR, limit, non-conform actions (drop, flag)
Classifier      DS Map
Class RED       minQ, drop probability, non-conform, maxQ
Class Shaper    CIR, limit, weight
Group Shaper    CIR




                                       Best generation networking
     MPLS TE/Composite Trunks/QoS


  WRED discards
    tunnel two or
 hop-by-hop traffic
during tunnel reroute

                               Compose Trunk




                                                           Subnet 1
       Subnet 1
                                                           Subnet 2
       Subnet 2



          QoS operates on Diff-serv inferred MPLS exp marking
                              Best generation networking
    Traffic Engineering with QoS
   Enables no-loss, low delay variance, low latency
    services
       Virtual Leased Line
       Voice over IP
       Storage Area Networks
   Add new properties to Service Level Agreements
   Improve reliability at reduced cost
   Deliver protection appropriate for each service, up-to
    SONET APS levels
   Improve utilization in network backbone



                          Best generation networking
Hardware features




            Avici Company Confidential
Architecture for the 21st Century Network
The Avici Systems TSR

                               • Carrier class features
                               • Carrier class design
                               • Unprecedented scaling
                               • Future proof




           Best generation networking
    Patent-pending Velociti™ Fabric
   Toroidal direct connect fabric
   Scales to 560 active modules
   Each element adds switching & forwarding capacity
       Generation 1 - 60 Gbps
       Generation 2 - 240 Gbps
   Each module connects to
    6 other modules
   Path diversity through fabric
       Resilient
       Non-blocking




                           Best generation networking
Growing the TSR System
               Expanding the interconnect
                      Two physical backplanes in each bay
                             Connected top-to-bottom
                             Connected side-to-side
                             Connected over-the-top
               Power Distribution
                      -48VDC 60A per shelf redundant feed
               Environment Controllers
                      Two per bay interconnected between
                       bays




          Best generation networking
    Avici Product Scalability



 1 TSR
400 Gbps                                                              6 TSR Bay
                                                                       2.4 Tbps
                                                          4 TSR Bay
                                                          1600 Gbps

                                        2 TSR
                                       800 Gbps
 1 SSR                SSR/TSR
200 Gbps              600 Gbps



            2 SSR
           400 Gbps
                             Best generation networking
TSR™ Interface Modules
                                           Packet over SONET/SDH
                                               Concurrent IP and MPLS
                                               1 port OC-192c/STM-64
                                               1 port OC48c/STM-16
                                               2 port OC48c/STM-16
                                               4 port OC12c/STM-4
                                               4 port OC3c/STM-1
                                               16 port OC3c/STM-1
                                           Ethernet
                                               2 port GbE
                                               8 port GbE Q2/02
                                               10GbE 2H/02




           Best generation networking
Module I/O Architecture


                                                              Multicast
   O/E         SONET       PPP/MPLS           Forwarding
                                                             Expander &
Conversion   Termination   Processing           Engine
                                                               Packet
                                                              Scheduler




                                                                                               BACKPLANE
                                                                             Switch


                                                                                      Fabric
                  Control Processor
                    FE Interface
                                                             Packet Memory
                                                                64 MB

   E/O         SONET       PPP/MPLS           Packet
Conversion   Termination   Processing          QoS




                                Best generation networking
       Software & System Architecture

                                                                      PowerPC
                                                                      Processor
                                                                         PowerPC
       OSPF    BGP4  IS-IS SNMP                                          Processor         Fast
         OSPF   BGP4    IS-IS SNMP                                                           Fast
                                                                                          Ethernet
                                                                                               Fast
                                                                                           Ethernet
                                                                                                Fast
                                                                                                           Routing and
                                                                                             Ethernet
        MSDP MBGP     PIM     FTP                                  SSD   PCMCIA
                                                                                               Ethernet   Configuration
          MSDP MBGP      PIM    FTP                                  HDD
        RSVP        CLI
                                                                           PCMCIA
                                                                                                              tasks
          RSVP        CLI                                        Control Processor            Console
                                Server Memory 580Mb                FE Interface
                                                                   Control Processor            Console
                                  Server Memory 320Mb                  FE Interface




                                                                      Multicast
    O/E           SONET           PPP/MPLS         Forwarding        Expander &
 Conversion     Termination       Processing         Engine              Multicast
       O/E           SONET           PPP/MPLS         Forwarding       Packet
                                                                        Expander &
                                                                             Multicast
    Conversion
           O/E
       Conversion
              O/E
                   Termination
                        SONET
                      Termination
                            SONET
                                     Processing
                                         PPP/MPLS
                                         Processing
                                            PPP/MPLS
                                                        Engine
                                                         Forwarding Scheduler
                                                           Engine
                                                                          Packet
                                                                            Expander &
                                                            Forwarding Scheduler
                                                                                Multicast                  Forwarding
                                                                              Packet
                                                                               Expander &




                                                                                              Switch


                                                                                       Switch Fabric
          Conversion      Termination
                      Control Processor
                                            Processing        Engine         Scheduler
                                                                                 Packet                    and Fabric

                                                                                            Switch


                                                                                            Fabric
                          FE Interface
                          Control Processor                                     Scheduler
                                                                                                          Routing tasks

                                                                                         Switch


                                                                                         Fabric
                             FE Interface
                        ModuleControl Processor




                                                                                       Fabric
                                 FE Interface
                                 Control Processor
   E/O           SONET          Server InterconnectPacket
                                 PPP/MPLS
Conversion
      E/O           Control Software
               Termination
                    SONET        Processing
                                    PPP/MPLS        QoSPacket                 Packet Memory
   Conversion
         E/O      Termination
                       SONET        Processing
                                        PPP/MPLS        QoS
                                                          Packet                   64 Mb
                                                                                                          Bay & & Environment
      Conversion
             E/O     Termination
                           SONET        Processing
                                           PPP/MPLS        QoS
                                                             Packet                                        Bay Environment
         Conversion                                                                                           Controller
                         Termination       Processing         QoS                                               Controller




                                                               Best generation networking
    Field proven operation
   First systems deployed in NTON (DARPA
    Supercomputer research network)
   Operational in the Internet in May 1999 (BGP)

   Currently deployed in one of the worlds largest carrier
    IP networks
   Support OC-192 links
   Operating as BGP Route Reflector in one of the
    worlds largest RR configurations




                         Best generation networking
AT&T network




          Best generation networking
         Summary




            Avici Company Confidential
Architecture for the 21st Century Network
    Summary - Carrier imperatives
   Cost
       Lower the cost of building and operating the network
   Velocity
       Decrease the time to add or change services
   Profit
       Deliver value added services and quality of service
        enhancements




                             Best generation networking
Lower Operational Costs

 Backbone Interfaces                                          Backbone Interfaces



                                       VS.


                                                                                High Speed
                                                                                 (Optical)
                                                                                IP Transit
                                                      Low Speed (electrical)
                                                   IP VPN / Low Speed Transit

 Low Speed (electrical)   High Speed
                           (Optical)

 Customer Facing Interfaces                                 Customer Facing Interfaces

 Current best practice                                          Avici alternative
                              Best generation networking
    Provisioning - Months to Minutes
                                                       14λ
                                                       10λ




                                       6λ

   Backbone capacity increased without truck-rolls
   Market share not impacted by provisioning
   Immediate provisioning for all bandwidth products up-to
    physical network capacity



Immediate fulfillment of customer demands
                          Best generation networking
     Velocity – Composite Links
   Avoid hitting the transmission capacity wall
   Backbone links with 64 times the capacity of our
    competitor on the same transmission network
   No impact to customer or network stability




    Backbone Capacity added in days not months

                        Best generation networking
    Profit
   Use IP core for converging all services
   Scale services past competitors offerings
   Spend your time creating new services…
       Make €€€€ at the edge of the network
       Save €€€€ at the core of the network




                           Best generation networking
     Conclusion
   Next generation public network switch
        Scalability
        Non-stop system and software architecture
        Quality of Service
        Network and Traffic Engineering
   Benefits
        Reduce capital costs
        Stable service velocity
        Increased equipment life cycle




         Faster, stable network expansion
    & dramatic reduction in cost per bit delivered
                             Best generation networking
        Thank You




            Avici Company Confidential
Architecture for the 21st Century Network

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:3
posted:10/29/2011
language:English
pages:41
xiaohuicaicai xiaohuicaicai
About